Longmill is On and Connected But not responding to Commands

Hi I’m having an issue with my machine when I turn it on I don’t hear the thump that always comes on when I turn my machine but my machine is on and when I connect it to my laptop it is connected because if I press the pause or stop button on my CNC it will show the alert on my laptop.

I was wondering if anyone has had this issue as well and how to fix it

Thank you

I have not had this problem but wonder if the emergency stop is the problem? You can connect to the machine even when the emergency button is pressed because the little arduino board still gets power. So if you have a way to check continuity on the emergency stop switch I would start there.

Do you mean the Emergency Stop button on the console because I have tried pressing it and starting and repressing it and still wouldn’t work

I meant the physical button, if you have one. Not sure if you have a longmill or another type of machine.

Edit: Rereading you original post and it seems like you do have a physical button. If it’s not a longmill I’m not sure if it would behave the same as my machine which is a longmill.

To elaborate on what I meant was that a longmill seems to power the arduino part of the system through the usb cable. I say this because with the physical E-STOP button pressed I can still connect to my machine and issue commands to jog around in gSender. Of course the machine does not move but gSender ‘thinks’ it does.

Based on this I suspected that your machine may be similar, and the arduino micro-controller is getting power but not the motors which is why I was thinking faulty E-STOP button or power supply. Could even be a tripped breaker if the laptop and machine are on different circuits.

Like I said if your machine is not a longmill it might work differently.

Yea honestly I’m not sure what needs to be fixed or replace you are correct it seems like everything is connected and receiving power expect the motors also yes I have a LongMill 30x30. How do I check if my machine and laptop are on the same circuit

Also would it be possible to get on a calls with you further explaining and troubleshooting it

Oh yeah longmill is in the name of your post, sorry for missing that. Are they plugged into the same outlet or power supply? I have mine on different outlets because with longmill, router, and vacuum on the same outlet it tripped the circuit breaker in the house electrical box.

Other than checking the E-STOP and power supply with a multi-meter I don’t know what to do. If you do have a multi-meter you could disconnect the switch and test it for continuity. Testing the power supply is a little more dangerous, live voltage, and I would not suggest it if you’ve never worked with electricity.

Also I forgot to ask if you put in a support ticket with SIENCI, they are the experts, I’m just a random dude on the internet. I wouldn’t intentionally steer you wrong but like I said they are the pros.

@SearsWoodshop @_Michael Michael has given you excellent advice. I would just ask what version of the Long Mill controller you have? Early versions of the controller had an issue with the on/off switch. Later versions addressed this.

If you can, look to see if the led’s on the motor drivers are all on. If they are not, you know that either the power brick is dead or the switch is bad, or the outlet that you have it plugged into is dead. First, I would test the outlet with another appliance/lamp.

ohhhh ok thank you @_Michael
Hi Grant @gwilki
My LongMill says on it
Rev 1.3

Also, I have no LEDs lighting up on my console, when I flip the switch I hear a lot of ticking it like the switch isn’t working but idk if it’s the brick but the outlet I used is fine I’ve used it for other things on it

@SearsWoodshop There have been several threads here on the issue that you are having. So far, the issue has been the on/off switch on the controller box on early models.

The solution is to bypass the switch. Here is one of the threads:

If you have a meter, you may want to confirm that the power brick is outputting the correct voltage before doing the switch bypass. Once bypassed, you will need to plug the brick into a switched power bar or something similar. Let us know how you make out.

Do I need to buy a replacement Controller now? Sorry, I don’t have a meter what do I have to replace to fix this issue, is this issue under any sort of warranty?

@SearsWoodshop If it is the switch, you do not need to buy a new controller. You just need to bridge the two terminals on the switch, as described in the post that I linked to.

If it turns out that the power supply is dead, bridging the switch will no nothing. It will not hurt anything. It simply will not solve your problem. So you really have nothing to lose by trying.

As I mentioned, if bridging the switch terminals solves your problem, you will need another way to turn the controller off. The simplest solution is to plug the controller into a switched power bar.

I do not believe this is under warranty, but you can write to Sienci to confirm.

Does a green light on my power brick mean that my power supply is good and working

@SearsWoodshop I believe so.

@gwilki I’m sorry I’m not very savvy with wiring I don’t understand the process of bridging do you know if I can send it to Sienci Labs to get it repaired.

@SearsWoodshop I’m sorry, but I don’t know. I suggest that you open a support ticket with Sienci. Go here to see the form:

Thank you very much I appreciate all of your help @gwilki @_Michael