Machine travel X Y 1.2.2 vs 1.4

So in the version 1.2.2 of gsender i had machine travel on X Y of max 574mm until it hit the limit sensors, but on 1.4. and above i only get 553mm ? how come?

…and sure, i did run a 100/100 calibration test and it measures exactly as expected

Again… Your settings.

1 Like

not really sure how to explain this to make myself understandable.
after i got the machine running on 1.2.2 i noticed that the maximum amount of travel with 553, wasn’t going near the limit sensors, so i recalculated to get the travel to go near the sensors, i ended up with 574mm

so i installed 1.4.3 again yesterday, and doing checks over checks, testing to see if everything is working i ran the machine from home, back-right to front-left using the jogging buttons (automated corner run) just to realize the maximum amount of travel was smaller, so i set the maximum amount of travel to 540 and increased the travel by small amounts until the machine would run from corner to corner without hitting the limit switches, but come very close to them (0.1mm), so now on this version in just 553mm i’l record a video later if it’s not clear

Can you just use a measuring tape to determine the actual value?

1 Like

@iuliancalin I believe that you have a typo in your most recent post. You have entered 547mm. From your previous post, I believe that you meant to enter 574.


Ok, so please don’t get mad at me, I was confused too at first when I changed g sender version.
I used the tape to measure, both x and y have around 553 554 so I rounded up 553.
It’s totally fine, don’t get me wrong.
The weird part was that in 1.2.2 I had set $130 and 131 to 574mm.
That’s what got me confused.

Are you talking specifically about using the Rapid position corner buttons? We changed how the max distance was calculated from 95% of max travel to max travel - 5mm between 1.2.2 and 1.4.X to be more consistent across all corners, which would probably explain why a max travel of 574 in the previous version didn’t hit the corner (because it actually only travelled 95% of that, which is 552mm).

In general rapid position is only as accurate as your EEPROM max travel settings. If your machine has a physical limit of ~553mm, that should be reflected properly in your EEPROM settings if you expect features to work as expected.

Oh, now that make sense. Thanks for clarifying

@iuliancalin Since Kevin has resolved your issue, @iuliancalin , I’m closing this topic.

1 Like