More X-Axis Woes need help/advice

@stevendq, which end of the cables did you swap? If you didn’t, try swapping at the stepper motors. This would also check the cables. First thing to check, and you’ve probably already done this, is to make sure the cable connectors are completely plugged in on both ends. Second thing is to make sure the screws are tight on the controller end connector.

Yes, what is going on? 3 of us now have this random problem that seems out of our control to fix. The worst part is it seemingly became defective for no apparent reason. I changed nothing, booted her up the the other day and now the controller is defective. @chrismakesstuff @andy any advice would be greatly appreciated!

Thats the most confusing part. After swapping the cables to determine that it was the controller, I am left scratching my head as to why this all of sudden craps out.

This is the second time I have had a bad controller. I see that they are out of stock which sucks as I have a ton of orders left to complete. Sorry to vent, its just frustrating.

Yes, this would be my second V2 controller as well. Similar problem as last time and the.same axis. I did not check the set screws but the cable swap was the first thing I tried. Also have about 6 or 7 jobs pending for the weekend. Checking the screws tonight and also checking to see if the wires were tinned as that has been an issue as well…still nothing changed from the last few months and now it’s not working.

I’ve seen some people reporting this on the FB group as well. Does doing a full reset of the arduino fix it?

A couple other reports of potential UGS incompatibility.

Trying to trace the issue right now

EDIT: Could you guys please let me know what REV version your controllers are? This might help me to see if this is a common problem among you all

In the meantime, here are some other related threads:

Previous solutions to similar problems have included:

  • be sure that all the connectors are all the way secured and each wire going to the connectors aren’t loose
  • check DIP switches on the motor drivers are fully seated (power off board before doing this)
  • slightly increasing the current coming from the driver by rotating the potentiometer on the driver clockwise (power off board before doing this)
  • if v-wheels are too tight and rails haven’t been cleaned on top and bottom then the gantry could snag on the debris on the rails - clean the rails and set your wheel appropriately
  • loose wires to power connector causing power instability - reconnected the power connector to the line from the brick and check that the motor drivers are staying lit even when the box is shaken around
  • checking all your grounds - whether it’s your dust collector, or running an extra ground from router all the way back to power source if the cable has nicks, cuts, or divots in it
  • change to a different electrical circuit / relocate laptop / try another laptop / change USB cable

@stevendq your issue may be different to @TightnTapered since yours is

just a little more randomly from no move to short move to quick move

It almost sounds like one of the wires to the connector is loose - maybe try a tug test on each of the wires to the connector on each side to ensure they’re all seated snugly. As @paullarson mentioned it may depend on which end of the cables you swap.

@Nic could you describe your problem in greater detail please? A video would also be very handy in helping to determine the underlying problem

The axis is doing pretty much the same thing, but my first thought was the dirt on the rails or v-wheels had come loose. Cleaned the rails and rechecked the wheels. Did have some play on the right side y axis which was corrected with a snug-up of the anti-backlash nut - but this is all z-gantry moving along the x axis.

I will check the connectors tonight, though I did do a wire swap at the motors and it didn’t change the problem. Will also try the wire swap at the controller and reloading the firmware. I will stick to this thread since you are troubleshooting a few problems and get you the controller version number.

Thanks @chrismakesstuff

1 Like

@chrismakesstuff: I did swap the Z with the X axis wires at the controller and tried to move X and it still wouldn’t actually move or move slightly. I can hear the stepper motor engaging, but not actually moving the axis. I am using UGS 8/10/20 Nightly, which has been performing great for several months. As I said in the other post, it was fine all night Sunday, until the very end of the night on my last carve that it started acting up, ruining the job I was running. As I said, the v-Wheels are sung but barely movable with my fingers and the gantry moves easily turning the threaded rod and the aluminum axis is clean. No side to side movement in the rod or left/right/up/down on the Z axis Gantry so the anti-backlash nut is as installed.

The Z cable was plugged in to X and X would not move using the Z jog commands in UGS. The Z did move fine using the X jog in UGS, so it is not the X axis cable. I also checked the wires to be sure they were tight in the plug and they were and since that cable moved the z axis, it is not the cable or plug.

I have a version 1.3 controller dated 1/11/2019.

See if this video link works: Video of issue 9/29/20

Have not as yet tried re-flashing the firmware, as I am not sure that needs to happen. I do have the software and the February 2020 firmware. Also not sure about changing the voltage on the potentiometer - not that I can’t - I can certainly try that if you think it would help. It’s just a pain getting to that pot.

Just a random thought. Is the coupler between the X axis stepper and the lead screw slipping? Are the set screws tight?

Wow. It really does sound like you have the same exact issue as I do. I haven’t tried messing with the voltage on the potentiometer either as it would require aot of time to access it (due to my poor design layout of my table).

I was going to attempt to reset my Arduino but I couldn’t find any literature on Sienci website that instructed us how to do it.

@chrismakesstuff my controller is REV 1.2.

1 Like

Yes, it is virtually the same, sometimes it will move a little other times not. I have the same issue with adjusting the pot — my controller is screwed to the table and it is tough to get at, not impossible.

If you go the the Longmill Resources, then on the left pane, click advanced you will see the link to GRBL Firmware here is the link: Grbl Firmware. You need to download the arduino program and the most current firmware version.

I have not tried the Firmware reset either yet - it’s getting late here, so maybe tomorrow. :frowning_face:

UPDATE: I re-flashed the Firmware and it did not make a difference. :pensive:

@paullarson No, I did check that as I had that issue with the V2 couplers and had to buy replacements. I watched the movement and there is no slipage and set screws are tight. It appears the stepper motor shaft is not turning.

@chrismakesstuff hey Chris I was able to fix my problem by reloading the firmware. Thanks to a tip from Kelly.
So it’s all working now. Other then my v-wheels are not tensioning right. But Kelly also helping me with that.

1 Like

Great to hear @Nic! I’m glad Kelly has been able to help you along :+1:

@stevendq your video is very insightful. Could you remove your x-axis motor and see if you can find that it’s spinning on its own? It’s very odd because in your video it sounds like the motor is spinning but clearly the gantry isn’t moving - almost seems like a coupler issue to me (although I know you’ve already spoken about fixing your couplers)

@TightnTapered I think you should do some of the same wire checks as Steve and also see:

  1. If it’s getting stuck at a specific part of the rail or all across
  2. If the threaded rod is easy to rotate by hand
  3. If it’s still possible to rotate the wheels by hand

@chrismakesstuff Yes, I can do that.

I did watch the shaft closely (had this issue before and replaced this coupler) when this is happening and the shaft is not spinning at all, or at least not consistently. it does move slightly or maybe a half turn, then does not move.

As with @stevendq issues I have no problems with the three suggestions that you listed. Anything else that you recommend? @chrismakesstuff

For you @TightnTapered I think if there’s no problem with loose wiring, electrical interference, or mechanical snags (rails, couplers, lead screws, wheels) my next thought would be the controller.

If you wouldn’t mind it would be beneficial for me to see one last video with your X and Z axis motor cables switched so I can hear if the motor is making a different sound, but otherwise I think a new controller might be in order.

@chrismakesstuff: Link to a video of what’s happening at the coupler/NEMA 23 motor shaft.

X axis woes Video 2

@chrismakesstuff, in an earlier post @stevendq stated that when he swapped cables at the controller he could move the Z axis with the X axis driver, but could not move the X axis with the Z axis driver. This would make me think the controller is OK and that maybe the stepper motor is bad. Actually, I’d like to think the lead screw is binding, but Steve said he could turn the lead screw manually.