Mid job cnc stops moving,

Hi, I have a problem. Mid job cnc stops moving, in UGS it shows “Running” , when I click on the Paus or Stop buttons in UGS it shows in console window that it have received the the commands, but the Play button stays grey. Also last line in console after the stop ">>> G1Z-15.000F328.9 "
After I restart the UGS it cant connect to the cnc, the “connect” button goes orange
as it should be, but in “controller statue” window it says “Off line” or “Disconnected”.
(Sorry English not my main language)

If you created the g-code in carbide create and have some different end mills in use, there is an entry made in the g-code telling you to change bits. UGS doesn’t recognize this. Open your code (ie:notebook) and scan the code for some lines beginning with an “M”. You can bracket ( ) the line or delete it to keep it from being part of the control code.

Hope this helps…

1 Like

I haven’t used UGS yet, are you saying UGS doesn’t support the bit change command at all or that Carbide is doing something unique around bit changes that UGS doesn’t support? If it’s the former, other than exporting individual toolpaths per bit type, how does one handle tool changes?


Hi Jeff,
I’ll let Sir Gregory or Chris answer the ‘handle bit changes at all’ question, but my understanding is that end mill changes are coded by carbide create (and handled within carbide motion, their version of UGS) with a line or two of code beginning with an M. There are a few other posts referencing this too.

As for handling changes, I am a newbie and just finished my first “production” run this morning, but used the same bit for everything…….

I have made all the toolpaths as separate g-code files, so I think that’s not the problem.

As did I, but that mysterious M code line was still embedded - beginning, middle and end!

The problem was not the “M” code line. When I get “M” error I just hit Send again, and the machine starts the job. My problem is that I get no error message, the machine just stops. I have now tried 4 times to finish the job, 4th was successful. 1,2,3 all stop in different places, so I dont think the problem is in g-code. Only thing I change at the last (4th) try was … I moved the vacuum cleaner further away.

I’m having the same issue with my raspbian build. Ugs platform and ugs classic both do it. I made the gcode with vectric aspire.

I’m only running 5 minute jobs, and I can’t get thru it. Any clues yet?

I see that this is a reasonably old thread, but I now have the same issue. I have been running a job created in VCarvePro and it has run fine for about an hour. Now, it just stopped. There are no warnings from UGS, the laptop running it has not gone to sleep, there are no M lines in the code.

If I reload the Gcode file, will the CNC start where it stopped and do I need to run the job all over again? I’ve tried pause and resend. I’ve tried using the pause and play buttons on the controller. Nothing.

I hate to lose the whole job.

If you’re running on a raspberry pi, I found out that the serial drivers cause this issue. In my case, the correct drivers were already installed and I just needed to select them in ugs. More details in the thread I posted about it the other day.

If not, sorry I can’t help.

I must admit to being very ignorant about what I am running on and serial drivers. I am running on the controller that Sienci provided. My serial port is 4. That jives with what device manager shows me in win7. I installed the most recent version of Java and supposedly, the correct drivers for the controller and ugs were installed. I have gotten some very small jobs to run, but this one runs for about an hour and it has crashed twice.

Can anyone reading this please tell me what version of UGS you have had success with? I am running the most recent version 2, but it says that it is a nightly release, which, to me, means not much better than beta. I see a version 2.0 in beta. The next older versions are 1.0.9, and they are not platform. They are classic.

Update: I had two one-hour long jobs run today. I spent some time re-installing Java and I installed an older version of UGS. So far, so good.

I was just going to say - I would roll back to an older version of UGS - I tried using a more recent version of the nightly build one time and had nothing but troubles with it.

I’ll stick with it until there is a new official release, then maybe update. Till then, I did a 5 hour v-carve and it worked well, so I am leaving well-enough alone.

Oh, another side note - the computer I am using was with a brand new copy of windows, fresh install, and I only installed what was needed to run the CNC , carbide 3d, fusion 360 and f-engrave. I know on my one mac that I use for work, I have so many different software dev environments set up that its sometimes a nightmare to set up for a new client - so the CNC machine was a clean slate.


1 Like

Tks, Mike. It’s good to hear that someone else had my problem and that the solution was to load an older version of UGS. It gives me confidence that I can proceed with more jobs without worrying about stalls.

1 Like

Well, Mike, the issue is back. I’m thinking that I should stick to more traditional woodworking. I simply cannot get this thing to be reliable.

Can you please tell me which version of UGS you are running? I was 30 minutes into a run and UGS simply froze - AGAIN! When it does, there is nothing that I can do to get it to continue. If I hit pause, run is greyed out so that’s it, that’s all.

@gwilki I know that feeling well! But don’t give up! I had a ton of issues trying to get the various versions of ugs to run consistently for me. I tried 2 different laptops, a desktop and finally bought a refurbed win 10 laptop and installed ugsplatform64 and all is reasonably well in my wee universe. And very very slowly I’m putting manners on the longmill. But the struggle is REAL!

Tks Br5d. The frustrating part is that the issue is intermittent, so just when I think all is well, it freezes again.I got the job that failed last night to run this afternoon. I have a job for a neighbour, but I’m not confident enough on this machine yet to take it on. There are a lot of resources online dealing with the same issue. I guess it’s just a matter of trial and error - mostly error. :slight_smile:

1 Like

So, just to add another observation - I started out using an older windows laptop I had - I tend to use to for my astrophotography, so its generally stable. However, there is some job that about 5-10 minutes after it starts up completely freezes the machine - you can move the mouse but it literally will not take any action till whatever it is completes. after that the machine runs fine.

Not wanting to deal with that, I set up my older desktop in the barn and installed a clean install of windows 10, java, carbide create, etc. That computer is almost 10 years old and is just fine - has an i5, 6 gig of ram, and a small SSD. Hardest part was getting wifi to work well out there.

Not saying you should necessarily wipe your computer, but just curious, how old is it, do you have a decent amount of ram, and do you have an SSD?

If you are using a Raspberry Pi, I have used one with a 3d printer with octoprint and for some other stuff but I might not be Abel help with this kind of issue, though I do have one I could try.

Well, here we go - or don’t go - again!

No more laptop. Desktop. 8Gb ram, 250Gb SSD. Nothing is loaded except windows 10 and UGS. All power settings are set to turn nothing off ever. Don’t go to sleep, don’t hibernate. Don’t go for a pee in mid job.

Today, the job that I had promised ran for just less than 30 minutes,with about the same left to go.

As with the other times, the longmill simply freezes. I hit pause, but run is greyed out. So, wood is ruined, time is lost, and I’m no further ahead with this thing than I was when this thread started.

I tried the last time this happened to edit the Gcode in UGS, remove the lines that it had run and start from where it left off. UGS seemed to edit the file, but did not output the shortened file in a format that it could read. So, I had to start the job all over again.

Rant done.

Well crap, that really sucks. On the bright side, you can rule out the computer seems like. Are you using the included usb cable? No USB hub in between?

Next time you go to try it don’t run the machine on wood - set the z axis zero and inch or so above the work piece. Then you can just let the machine cut air with the router off and see what is going on.

I’m not sure if there is any other way to get some debugging or logging out of UGS or the controls box, @chrismakesstuff or Andy might need to ask some more questions. I’d be curious that the power to the control box is staying consistent, and the usb cable is good.

Other issue might be UGS - might be time to try one of the other programs - look at https://sienci.com/dmx-longmill/machine-interface/ . I have no experience with other ones, but cncjs looks “fairly” straightforward to get going.

Sorry you are having trouble!


1 Like

Mike: Crap is mind compared to what I was saying this afternoon. :slight_smile:

I ended up running it again and it ran. So then, I opened the second tool path for this job. This path consisted of cutting 2 rectangles. That’s it. It froze part way through the first one. So, that ruled out file size, which was one factor that I read could cause UGS to freak.

Today, I tried it with both the included usb cable and a new, longer one that I bought. No joy, there, either.

One thing that I have read online is that these things are uber sensitive to electrical interference. Tomorrow, I am going to take the router power cable out of the drag chain. It is in there now with the motor cables, which are completely unshielded. I’ll try that for a while.

When that fails (notice my optimism), I think that I’ll move to grblgru. It’s not based on Java as some of the others are. I’m grasping at straws here.

I want to post onto the ugs google group, so I’ve asked Chris for some specs on the controller. I only know enough to know that I don’t know enough. On that group, they get pretty technical trying to diagnose problems. Time will tell.

All that I know for sure is that I can’t keep this up. I can’t make promises to people only to find that the machine is so undependable as to be useless.

Take care.