Z-Axis instability - plea for help

I posted the following on Facebook, but I’m repeating it here in hopes of getting help in solving this problem:

Now that I have my LongMill assembled with a working controller, I can start making the necessary adjustments…

The X and Y movement seems fine, but I’m having trouble with the Z motion. I’ve made several attempts at a simple sign for my grandsons, working in MDF (much better than pine :blush:). It simply says “Ben and Alex’s” / “Room” on 2 lines.

The first time after the first couple of letters, the depth of cut started becoming more shallow; I stopped it when it was cutting in the air.

Next time after the first couple of letters vertical movement was suddenly just a jerking of the carriage.

Third time after the first letter rather than move vertically to the next letter, it started reversing INTO the stock and getting stuck. After stopping the toolpath I had to jog it upwards 10mm several times to get it loose.

OBVIOUSLY something needs adjustment. What do I adjust and how?

reply 1

[Andy Lee] Can you check that the two pulleys on the z axis are tight and the z axis motor cable is secure?

reply 2

[Tom Woodhouse] And, as always, make sure your electrical connections are tight-but not too tight…(Andy Lee)

reply 3

[Frank Alviani] The pulley on the stepper motor was a little loose, so I tightened both set screws. The connector to the stepper itself was tight.
Good news when trying the sign again: The letter depths were correct and consistent.
Bad news: it got through “Ben and Ale” when it went up too far and stayed there. The set screws were still tight when I checked.
What next?

reply 4

[Frank Alviani] Followup: I made an almost identical file in Vectric Desktop, using the same fonts. When I tried to carve it from UGS, it did “Ben and” and stopped moving on the final d. Different code, but the cuts looked the same up to the last letter. The pulleys were tight on the shafts.

Sounds like you may have had multiple problems. Hopefully tightening the pulleys fixed one of them. What was UGS doing when the the CNC stopped before completing the signs? Any other programs running on your PC, foreground or backbround, that may be interfering with UGS?

Ok, the pulleys are tight but do you have enough tension on the belt so it is not slipping. Just a thought.

I had similar problems right after completing my build, and in every case it was caused by a loose connection, usually the plug into the motor. They feel like they’re in but you really need to squeeze them hard to be sure. Be careful with all the plugs not to bend over the wires. Even when I thought they were in correctly the Y motors suddenly started jerking and even going the wrong direction - When left goes positive and right goes negative, the E-Stop came in handy. Double check and make sure.

Good luck. Keep us updated. Have fun. Stay safe.


Here’s what I have just done:

  1. The plate at the top holding the two shafts wtih pulleys on the Z gantry was very slightly not totally tight. I tightened it, probably no more that 0.1 mm. The belt is quite tight.
  2. I loaded the file I’ve been testing with and set the work coordinates. Set the Makita to 4 (roughly 22K).
  3. Started the cut. It cut “Ben an” and stopped moving partway through the “d”.
  4. From then on, couldn’t jog Z axis, After a few attempts, couldn’t job X or Y either.
  5. With the power off, re tightened ALL of the signal cable connectors to the control box. No change. Can’t jog.
  6. Tried using Candle to check. Could job once or twice, then lost the ability to jog.
  7. Downloaded the latest copy of UGS nightly, 64-bit. No improvement.
  8. Tried clicking the ‘run’ button on the controller to see what the effect is. No improvement.
  9. Checked the power brick connection to the controller. Looks solid. I trimmed off the soldered wire ends and reconnected the connector a few days ago to get it working in the first place.
  10. Retightened the power plug again. When I tried it, I was able to print a few letters before I lost the ability to jog.

At this point, I’m doubtful that the problem is mechanical. The fact that I can no longer jog on any of the axes reliably points to the control box itself or the power supply. This is a BRAND NEW control box that replaced the original one that proved defective.

The fact that all of the senders are having trouble may mean a connection problem. Make sure the USB cable is plugged in completely on both ends, and try a different one. Plug directly into the PC if you’re using an extender or multiple port block.

Hmm, going from general electronics experience and not specifically related to the Longmill, this comment really caught my attention.

What do you know about the circuit your Longmill is currently plugged in to? What else is on the same breaker? Are you running a vaccum and is it on the same circuit, for example? I’d be tempted to get a heavy guage extension cord and find an outlet I am confident is on a different breaker than you have been using, and hook up to that. I am wondering if you are have a brown out on the incoming power due to a load elsewhere in the shop or house?

Likewise, you say you replaced your controller but did you get a second power supply with it, or is this the same power supply? Perhaps the PSU is not putting out stable power? That could cause all kinds of inconsistencies. Hard to check though as most of us don’t have a 24V/10A supply kicking around from anything else.


I’m late to this game, and most of what I could offer has already been said and tried.

When my mill was erratic, it came down to electrical interference. It took quite a bit of finagling to finally solve it. One of my issues was static from my dust collection. I use solid ABS to get the connection close to the middle of the spoil board, then flex from there to the router dust shoe. Until I grounded it, I was getting some weird stuff happening. All that said, take a look at anything you believe could be causing a problem, however obscure, and move or change it. If the USB cable is close to another, move it. It’s frustrating, but I’m betting that you’ll fix this.

I have the original power supply. They didn’t send a new one with the replacement controller.
I reseated all motor cables on both ends, even though none of them felt even slightly loose.
Replaced USB cable, and plugged directly into computer rather than hub.

Different code sender (Candle) - no change in behavior.

Even though the jogs are being sent as expected - say 10mm X or Y - the carriage is only moving 2mm on average. Or it will move as expected several times, then fail. Sometimes it will start working properly for a few jogs, then quit.

My machine is in my garage. I don’t have the luxury of moving to a different breaker.

Thanks for suggestions. I’m running out of ideas.

I totally empathize with you, I was in a very similar spot yesterday and felt like giving up even though I have been totally impressed with the machine overall. After a couple of failed cuts I was dismayed.

What I discovered on the Z was that I had to both tighten the set screws and belt, while tensions (which I believe you have done) and then I noticed I have play in the Z assembly. Grip the right lower corner and gently wiggle it and see if it moves. Mine rattled and moved. I carefully and slowly adjusted the eccentric nuts a tiny bit at a time on both sides until the wheels were still movable by hand (looser at the bottom than the top, since the weight is on the top ones, the top ones on mine don’t move too much by hand now) and then when I was happy I redid the wiggle test. Now it barely moves at all when wiggled from the corner and the vertical motion is nice and smooth from the motor.

Give that a shot and see what happens.

Bummer about not being able to run from another power source. Is a temporary 50’ cable to the house an option? Since you’re not running at heavy load it likely is not the power, but unstable power can cause all kinds of weirdness with precision electronics. If it is power, I suspect the supply more than the circuit, but without knowing how old the house is, what else is on the circuit you’re on etc etc. it’s hard to say. I wouldn’t rule power out at this point is all I’m saying… In my experience, a surprising number of electronic things, especially varied weirdness, trace back to unstable power.


For the sake of posterity and helping improve the machine over time… @chrismakesstuff what is the history of the connectors on the motors? Are those defined by LDO and you have to work with them or are those a choice Sienci made and ordered them as an option on the motors? I would say loose connections are a very high frequency comment here and those connectors don’t inspire as much confidence as, say, the molex connectors that power a hard drive in a PC. And a PC rarely gets shaken the way a CNC does. I’m surprised the connctors don’t have a positive tab lock.

When looking at refining the design I would suggest you look to automotive electrical connectors that are designed for noise, vibration and harshness - the same situation the CNC has. Positive locks would go a long way to helping resolve many of these issues. Likewise, it would be an improvement for the ends that connect to the Longboard to also have positive locks so they can’t clandestinely shake loose over weeks of use.

In the same vein, and I mentioned this on the phone to Andy yesterday, it seems to me that a review of the power supply rails might yield some opportunities for improvement. If I understand correctly, there are multiple sub-systems that are sharing the 24v/10A supply. I’m guessing one each for the stepper drives and one for the Arduino and possibly others? Given that 24v/10A power supplies are not very common, but lower amp 24v supplies and 12v supplies are, it begs the question whether or not you could sub-divide the power and use 2x 24V supplies at a more common amperage or alternatively 2x12v supplies if that is feasible? Once you get to 12V supplies your options open up considerably but I realize the higher voltage is ideal for the torque we need. I’m not a power engineer but have sat in on enough design meetings to recognize that there is an opportunity for improvement that should hopefully move you towards a more widely available power brick or bricks.


The garage is on a 200 Amp circuit directly off the main box of the house; there’s a local breaker box. If power cleanliness is a concern, what kind of conditioner would you recommend? According to my back of the envelope calcs, 20 Amps would be sufficient for both the LongMill and the Makita 0701. This is way out of my area of expertise (retired programmer)…

Thanks in advance

That should be fine under normal circumstances. You could try setting the Z axis zero point a couple inches (several centimeters) above the work surface, leave the router off and air cut your sign. The router should be the largest source of noise. If you have a shop vac running leave it off, too. If it still exhibits problems the problem probably isn’t noise.

There is a green LED power indicator on the power brick. Is it on? I suspect it is or your couldn’t do anything.
Are the four red LEDs on the side of the Longmill Controller on solidly? Even during failure?
There are four dip switches in the controller, one on each of the driver boards. It was recommended that even if they look like they are set right each switch should be moved to the opposite position and then moved back to the correct position to make sure. You will probably have to take the controller enclosure apart to do this. All four should be set the same way.

I don’t know if any of these things apply to your situation, but it couldn’t hurt to check.

Sounds like you’re covered on the mains power. Without any background I was just taking a stab at it. My situation is almost the inverse of yours. The original builder of the house didn’t want/need more than 2 circuits in the garage and in addition to tools they all have other garage functions on them like door opens and a sprinkler control, so my power budget is sub-optimal.


Latest: I tried an “air cut” without the router running, with the controller (precariously) balanced on end so I could see the driver lights. It start out OK and seemed to cut a number of letters, then suddenly just started jerking, and all 4 driver lights were flashing with each jerk, in unison. Not good, but I don’t know what that means.
I will try to make a short video to clarify.
Looking for suggestions / advice.

To me it sounds like a bad controller, possibly the power brick if it’s having intermittent issues. If it were me, I’d take the controller out of it’s enclosure and reset the four dip switches as I mentioned above, if you haven’t already done it. I think Andy mentioned this in the assembly instructions. While your at it, check to see if any of the socketed components on the enclosure are loose.

I will try that tomorrow (I am committed for the rest of today). I ran another dry cut without the Makita, and it went about 9 minutes before failing. I believe the power supply is behaving itself at this point, although I still don’t like the connectors they used. There must be a more solid alternative.

I don’t look forward to having to totally disassemble their controller; I can’t imagine it would be a lot more complex to have a bottom panel that’s easily removable to access the drivers (assuming they’re mounted so I can just access them - which seems likely since I can see the lights).

This is my 2nd controller :rage:

Thanks for the feedback.

If it’s the original controller, it’s pretty easy to get out of the enclosure. Just screws on the end plates. I’m not suggesting that you try to take it any further apart than getting the board out of the enclosure. I think the driver boards are actually soldered into the main board. Good luck. I went through some of the same issues, i.e. stopping mid project and flashing red LEDs. A second controller fixed my issues.

Hi Frank, I got your email with the video. This helps me a lot.

The machine seems to be running properly from the beginning, then it appears that the lights that are flashing/stuttering in a constant repeated manner is caused by overcurrent protection built into the power supply. This would happen if the power supply shorts for any reason, and stops the power from coming from the power supply.

Please double check that the wires from the power supply are not crossing and are properly secured. This is the part where you cut and resecured the wires to the green plug.

Here are some other notes:

  • The problem is not caused due to the gcode sender or code since you have been able to successfully run the machine
  • The DIP switches appear to be set correctly. If they were not, then you would not get any movement at all
  • The new controllers have filtering against noise that should eliminate issues with vacuums/routers (although it is a very good idea to still keep everything shielded and grounded as nothing is ever perfectly protected from EMF)
  • It is not likely that your power outlet is causing issues, as long as you are running off standard household power it should be fine.

Just as a quick note for everyone, I would like to mention that if you require help, a video typically is the by far most helpful piece of information to have for support, as we can identify the issue more easily by visually seeing the machine function and listening to the noise. I have put together a short guideline that can help us with technical support here (https://sienci.com/contact-us/technical-help/)

Let me know how it works out!



Unfortunately, it’s the new version and as far as I can see I need to totally disassemble it. Not thrilled. I’ve got an email in to Andy to see if he has any recommendations. Here’s a link to the video : https://my.pcloud.com/publink/show?code=XZsUrTkZGXNV1FdJFEbTg3rJl8Ab17Bz64wy