My Long Mill is acting up

Went to do some carving today and the machine is acting like it doesn’t know where it is or where to go. I created a file in v carve pro as usual, set zero as usual, I have tried both center and lower left datum. I have tried several files and when I start a carve file it is starting in a random location. I am trying to carve a pocket, 4" diameter circle 1/16" deep. The file has the circle in the center of 10.5" X 7.75" 3/4 plywood.

It’s like the long mill does not know where to begin the carve. Help

BTW I have restarted the computer, powered the controller down, it jogs properly.

@Bill I could look at the .crv file, but the version of vcarvepro that I have access to is 9.5. If you are using newer, I will not be able to read it.
I can run your gcode it you like. Post it here.
What gcode sender are you using?

1 Like

Hi Grant, mine is 10.5, I reset everything, checked the cables and like I said jogging is fine, even the diagonal jog, works fine, sounds fine. If I set the datum to the lower left, it move on the y axis about 1.5 inches and starts carving there, no diagonal movement towards the center of the piece whatsoever.

How can i put the g code on the forum?

Cork Jig cork pocket.gcode (2.5 KB) Cork jig for coaster coaster pocket.gcode (2.8 KB)

Thought I could only upload pics.

@Bill I have the files, Bill. I’ll run them and get back to you.

Just FMI, what gcode sender are you using, UGS?

UGS Platform, tried source rabbit and it does the same.

@Bill Almost dinner time, but I ran both of them on my test arduino uno board, using UGS and they both ran fine. I’ll try to get time to run them on the Mill tonight. If I don’t, I’ll run them tomorrow for sure.

You are indeed a generous gentleman for sure! Thanks, appreciate you help

@Bill I’ll be testing it this morning, Bill. One thing, though. If you are not using grbl inch as your post processor, you should be.

1 Like

@gwilki yes sir, grbl inch, the project is just a simple jig for centering self adhesive cork to the back of a coaster. Made new files to try again and same issue.

Cork Jig cork pocket.gcode (2.5 KB)
Cork jig for coaster coaster pocket.gcode (2.8 KB)

@Bill Before going downstairs, I’m just making your project in my version of vcarve to compare your gcode to mine. What bit are you using?

Here is the gcode for mine. I used a 1/4" mill. I have not run it yet. I can see some differences between this one and yours. Not sure if they are significant yet. I set X0Y0 to lower left corner. Z0 to top of material

Pocket 1.gcode (21.4 KB)

edit: I’ve just sent you a private message.

@gwilki, yes, .250 EM, XOYO lower left, Z top of surface. Not using the plate, I sometimes feel it more trouble than it’s worth. I will try your file in the meantime. I also have a couple of things to do this am. Again, appreciate the help.

Tried your file same thing, here is a pic

Like I said starting from lower left it does not travel to the center of the piece, moves straight back on the y axis a couple of inches and begins to carve

@Bill This one really has me puzzled, Bill. Clearly, the controller is sending signals to the X motor, since you can cut a circle. Just as clearly, the gcode shows an initial command to move the X axis 5.25".

When you run the toolpath in VCarve and preview it, what does it show? Is that initial move in X shown?

Can you post a screencap of the material setup screen from Vectric and of the pocket toolpath?

1 Like

@gwilki Tech support told me to call V Carve, not a response I expected or appreciated, my wife and I now have orders coming in and this cnc has stopped working, can’t do a thing with it…

I have done this project before, had to change it to a different size cork

Something like this:

The 4" circle holds the coaster centered, slightly deeper is the pocket for the cork, 3.5" pocket, did it before no problems.

I am thinking of reloading the Firmware, what’s your thoughts on that. I do leave everything powered up, maybe a power fluctuation caused an issue?

@Bill I can’t agree with Sienci tech support on this one. The gcode looks fine and it works in my machine. It clearly shows a move in X before carving starts. So, the issue is that, for some strange reason, your Mill is ignoring that initial X move. However, it then accepts the subsequent X moves, proven by the fact that it carves a circle. Add to that the fact that it cannot properly carve the file that I sent to you, which I can carve.

All this says to me, at least, that something is wrong with your controller. I am far, far from expert on the inner workings of the controller, but I can’t see it being anything else. It may be a good idea to re-flash the firmware on the arduino. It can’t hurt.

That said, if you don’t mind, try this file, please. It is the one that I sent you this morning, with one small edit. Just run it in air. I would just like to see if the X move at the outset takes place.

Pocket 1.gcode (21.4 KB)

@ gwilki will give it a try, I have a fair amount of carving backed up and don’t want to scar up special wood glueups, such a simple task before I get started. I am a little disappointed with tech support.

@ gwilki Same issue with that file also, goes to same location as before

@Bill Well, Bill, I am officially stumped. That file separated out the initial X move from the initial Y move. It was a long shot.

I can’t say that I blame you about your disappointment with tech support. Did they run your gcode? If they did, and it worked, as it did for me, then clearly it is a hardware issue.

I guess it’s down to your idea of flashing the arduino. If you do that, please post how it works out. I’m sorry that I couldn’t be of more help. :frowning_face:

@gwilki you have been a major help, going to flash it for a try.

Hey Bill, noticed your thread here and just as stumped as Grant since clearly you’ve got motion in both directions. Could you try running this job again but higher up in the air and take a video when you start the job, it would help me to hear if perhaps your stepper is acting up, or if your zero point isn’t being set correctly, or whatever other issue might be happening here.