My projects are now off centered to my workpiece

I’m using Carbide Create and gSender, but all of a sudden my design is off centered with my workpiece. I thought perhaps one of my rails was ahead of the other causing this, so I ran them all the way to the rear of the machine until both motors grinded, that didn’t help. When cutting, my design ends up higher and off centered to the right. I sent the file I’m using to a friend to see what he came up with, he didn’t find any issues and came out with a perfect cut. I’m puzzled, could it be Carbide Create, gSender or my Longmill?..any thought/suggestions would be greatly appreciated.

@46er12003 - Kevin, forgive me if this seems really basic, but are you sure the size of your workpiece matches the size of the work piece in your CAD program?

I had a problem with a project where when I ran my outline and it was off. I had forgot to move my start position from center where it was when designing the project to lower left corner where I was zeroing my machine.

Just a thought.


Hey Steven, thanks for the response. I’m absolutely 100% positive that the numbers are the same.

1 Like

@46er12003 The other thing I was thinking is mm vs inches - carving and setting up in the same units of measure. Other than that, you may want to submit a support request to Sienci. Seems strange if the file is OK on another system, but not on yours.

@stevendq It’s quite puzzling indeed. After the results from a friend, who didn’t have issues on his end with the very file I was using, I knew it had to be my machine. Thanks for your responses and I’ll keep the forum up to date on my findings.

@46er12003 Kevin: How far off centre is it? Are you setting your XY0 in the front left corner using the touchplate? Are you using the bit size that you have input into the probe module? Questions, questions. :grinning:

@gwilki It’s at least an inch off and I’m zeroing with my touch plate in the front left corner. I’ve checked everything I can possibly think of. Do you think by having a power strip with a few other things plugged into would affect the cut?

@46er12003 I really doubt that the power strip has anything to do with it.

Is it doing this with all files or just the one? If just this one, post the gcode if you like so users here can take a look at it.

You might want to set your zeros without using the touchplate, just to eliminate it from the equation. Jog until the centre of the bit is over the corner of your material, set zeroes and run the file.

I’ll try zeroing without the touch plate first thing in the morning. Appreciate it

HD (1.2 MB)

Here’s the second gcode, V-Carve only.
HD (92.3 KB)

@46er12003 What is your material size? You are setting XY0 at the front left corner, yes?

Oh, is this the only file causing the problem or does it happen with all your projects?

edit. FWIW, I just opened it in ncviewer and it is off centre. So, at first glance, it would appear that this is neither a gSender nor a Long Mill issue, with all respect to your friend who got it to work. You can look at it on if you like.

I’d second this approach.

Marty Schlosser
Kingston, ON

I really appreciate you taking the time to look into my issue. Would you have any suggestion as to what my next move is to resolve this.

@gwilki Here’s the file I sent to my friend who didn’t have issues with it being off centered. Because I really don’t know what I’m looking at in ncviewer, I’d appreciate it if you could view this file as well.
HD-Union-Stars-no-depth-60V-NO-Clearing-NO-depth-60V_1-2-Stars-.15d-60V.gcode (518.7 KB)

Looks to me like this is off-center as well.


@46er12003 I’ll take a look at it shortly, Kevin, but please tell me what your material size is? Since you are setting XY0 at the front left corner, I need that information to run this on my Mill.

I really appreciate it Grant…my union size is 15" x 10.5"

1 Like

@46er12003 I just ran the outline of that file with a V bit scratching cardboard. The outline is perfectly centred.