No continuous jogging in 1.2.0,1.2.1, 1.2.2

Seems to be a bug in gSender 1.2.0, 1.2.1 and 1.2.2 at least on my two computers with windows 10, I can’t get them to do continuous jogging like in version 1.1.7 I emailed them about it they gave some suggestion but none worked. I always home machine first after homing click and hold the on screen buttons gives a tiny movement and error 15 on X and Y buy Z works as it should single click moves the preset amount if i disable soft limits continuous jogging works great when enabled again no more continuous jogging. Anyone know if I’m missing something some where or
something I must click to make it work ? In 1.1.7 I did nothing and it worked great .
Machine is a stock skapeoko 3 xxl

Are the machine dimensions set correctly in the firmware? They are $130, $131 and $132.

Yes, Same as in version 1.1.7 that works great and are correct for my shapeoko xxl

I downloaded 1.2.2 source code looking at it under jogcontrol a large section is commented out not sure if that has anything to do with it since I’m not a programmer

All I can think of is a settings problem. Are $20, $21 and $22 all enabled?

No just $20 and $22 are enabled but not $21

I think you need $21 enabled that’s hard limit’s.

Just to verify you mention that you home at start so I assume that you have limit switches or sensors. The next question is are there two switches per axis or just one?

My machine is a LongMill and has one sensor per axis. So for me $21 is enabled for hard limits, $22 is enabled to allow homing and $20 is enabled for soft limits. Soft limits work in conjunction with the dimensions in $130-$132 and throw the Error 15 when it calculates that a move will end up out of bounds.

If your machine has a switch at both ends of an axis then I think you can leave $20 soft limits disabled, but unless I’m wrong your always going to want $21 enabled for hard limits with any switch setup.

Where about on the board are you homing to? Right hand rear corner, left hand front corner etc.
It can make a difference when homing with Soft limits set but no Limit switches set

Well I tried the enabled $21 hard limit’s but same results still no continuous jogging, The shapeoko comes with sensors one on each axis

Homing is on right hand rear corner, Not sure why that should matter because gSender 1.1.7 works with continuous jogging on all axis and soft limits set and homing to right hand rear

I found that the source code in 1.2.2 is not the same as 1.1.7

Can you get a screenshot of the jogging UI with the console open?

As an aid to diagnosing this and FWIW,I can jog continuously in all axes using the GUI and using keyboard shortcuts. I have my keyboard shortcuts mapped to an app on an Android tablet, and all the jogging controls function until I release. This has been the case in 1.2.0, 1.2.1. and 1.2.2.

Like the OP, I am running windows 10 21H2, 64 bit.


There was a regression in how we handle continuous jogging for machines not running our firmware (since you have a Shapeoko, this is almost certainly the case) which is compiled to set machine 0 where the machine is homed to. This will be fixed for the next release.

I’m sure if you check your console, you’ll see travel exceeded errors when attempting to continuous jog. The travel directions got flipped, so it’s calculating the inverse of the maximum travel it can do in any direction.

1 Like

You are correct on the travel exceeded errors, I did know about the (regression) if not running
your firmware now it make sense, I just knew it all work in 1.1.7 but wanted to try fix location tool change that worked by the way. I’ll be watching for the next release, THANKS to all the guys on here for all you help an suggestions. I’ll stay with 1.1.7 until the new release

A post was split to a new topic: Fixed location tool change issue