Problems with my X axis

I’ve been using my longmill all week and it has been fine. I just turned it on and the X axis won’t jog although I can hear the motor hum. It won’t move using Gsender in rapid or normal but when jogging on precise if I twist the lead screw manually to start it off it starts to jog fine. It won’t jog at all using UGS. I unplugged the x axis from the control board and swapped it with the Z and it jogs at all three settings. Any idea what I need to do?

When you swapped the X and Z did the jogging problem move to the Z axis?

My thinking is that if you swap them and the X still has the problem then it’s something to do with the X drive train, anything from the X motor to the X lead screw coupler, backlash to tight etc.

On the other hand if when you swap them the problem moves to the Z axis then it’s something to do with stuff before the motor, wiring control box etc.

I’ve just tried now as I didn’t plug the z into the x. Yes, when I swap them X axis moves fine using the Z axis buttons but the z axis has the same issue and won’t move using the X axis buttons.

Any ideas how to fix?

Unfortunately I think I’m better with the mechanical side than the electronics side so I’m not sure of how to check anything except for the dip switches. You can read about them here.

Other than checking those I’m out of my depth with the electronics.

EDIT: You can also check for any lose wires or damage in the X part of the wiring.

Cheers for the help Michael :+1:t5:

Actually that article is about adjusting the potentiometer but you can see the dip switches in the photo. Good luck and your welcome sir.

I’ve just tried flashing the firmware but it didn’t help.

I’ll wait to see if anyone else has any ideas as I don’t fully understand what I’m doing with the dips and don’t want to make it any worse.

1 Like

That’s probably wise, all I could do with them is make sure they’re in the right spots. I think this problem is probably control box related and would contact Sienci for advise on how to proceed if it was me, especially if you don’t get someone fairly knowledgeable with electronics to respond here.

@Teeman Since it has worked in the past, I doubt that it is the dip switches. I would lean to it being a bad motor driver. If so, the solution is to replace the Long Board.

It would be best o open a support ticket with Sienci to determine the true cause, though.


Cheers Grant I’ve contacted Sienci. I’ll keep everyone updated.

1 Like

Unfortunately after speaking to Sienci I need a new long board. They can’t guarantee it won’t happen again although they say the newer boards are better than the ones from 3 years ago. :sob:

2 posts were split to a new topic: Z axis jogging in reverse

Cheers, found the solution after I posted. After updatinng your firmware you need to restore defaults which switches it back.