Running gSender w/o a CNC machine

I’m wondering is it possible to run (simulate) a gcode file in gSender without having a CNC machine attached to it?

Scenario: the CNC machine is located in a ‘remote’ shop and I want to test my design in gSender as a ‘dry test’ before running it in gSender with the CNC machine attached to it.
Is that possible?

Any qualified feedback is much appreciated.


@drobble I just tried to do that in gSender without a machine attached and while I could load the file, I could not run it.

If this is something that you want to do often, you can buy an arduino uno, flash it with the Long Mill firmware and use it as a “test machine”. I and others on here do that.

You can also run the gcode in a simulator. is a popular one. There are others.


One popular 3 axis simulation software is the excellent open source CAMotics. (the software is free and runs on a PC or a Mac) This will likely do what you want and it has a very high degree of configuration adjustment. One recent example I have is this image from a carve of 3mm Dibond for a machine that will drive very light high speed stepper motors and work as a 3D printer. This shows a little of the interface.

Yes you can either with some free software or as I did with an arduino uno hooked to my design computer. I downloaded the GRBL firmware from Sienci and installed it or you can start gsender and flash with that (easier). I just connect using gsender and test away. There are limitations such as not being able to use probe or anything that requires metallic or sensor contact unless you want to simulate by touching wires together (not very accurate). I found this way to be more satisfying and feel safer knowing it will run on the cnc. A plus is having a spare arduino if needed. Happy carving!

1 Like

Thanks to all for the suggestions above.
I tried already ncviewer and it appears it’s doing what 'm looking for. The only caveat is that I have to e online to use it.
I also downloaded (and installed) the Linux version (deb package on Mint) of CAMotics. However when I launch the app nothing happens. I will look into that a little bit deeper in the next few days. It appears there no AppImage version available, which would be nice).
And finally, I don’t think I will go down the ‘Arduino’ road. I have already some RasPi lying around and will not add another hardware platform to my ‘inventory’ LOL. But perhaps later I will change my mind in regards to that.
Anyway, many thanks for your feedback.

There are pre-built Debian packages, including Mint. I cannot remember where I saw something specific and relevant about running CAMotics on Debian Linux. Anyhow, about 3/4 down the linked page you should be able to find what you need.


I already downloaded/installed the deb package from the CAMotics website (not from Github).
As you can see from my previous posting, nothing happens when launching the app.
No indication for missing components or libraries. It’s just dead after launch.

Allows CAMotics perhaps some command line parameters?

I see that. I was not trying to make life difficult for you. I saw some very specific stuff for Linux Mint distro.

I am not sure if this was it… the link descriptor starts: " If CAMotics won’t run or you don’t see the 3D view try updating your graphics drivers. Debian Linux To install a Debian Linux .deb package open a terminal and run the following: # Go to the directory where you downloaded the CAMotics package. sudo apt-get update sudo apt-get install -y gdebi sudo gdebi camotics_1.2.0_amd64.deb

It also looks like a solution was found in google groups very recently. Sep 2022. I hope this helps.

After tinkering around for quote a while to resolve the problem during start of CAMotics, I figured out that the library libv8.3.14.5_3.14.5.8-11ubuntu1_amd.deb was missing.
Too bad that there are no required dependencies for this app listed. But I think that’s a comment I should post on CAMotics website.
Anyway, Camotics is now working for me (and it looks pretty good).
Thanks all.

1 Like

Glad to know you got it working


is there some specific wiring on the Uno needed or can I just plug the Arduino to my host via USB?
Is gSender expecting any feedback signals form the CNC router to functioning properly?

Just curious :slight_smile:


@drobble - No wiring is required other than the USB cable unless you want to simulate the probe or some other physical function. But that is not very accurate since you’re guessing when to touch the wires together. But it does work. No feedback from the router. You will need to install the Sienci firmware but you can do that from gSender. I don’t use it very much but it does help when I need to test some things.