SLB_LASER not found gSender 1.4.6

I just installed the SLB on my MK1 system.
Everything was looking good up until i tried to bring the LaserBeam up and the “SLB_LASER” option was not available with “default spindle” being the only option in the drop down menu and the laser did not test fire on any power setting.

Any suggestions on how to make the “SLB_LASER” show up on the drop down?

Thanks!
Ray

I did find a work tenable workaround that may help anyone else who has found this problem:
My MK1 does not have a spindle just a plan old router. So changed firmware register 395 Default Spindle from its default of “SLB_SPINDLE” to “SLB_LASER”.
This change allows me to fire and control the power of the laser on both the Sience LaserBeam and my 3rd part 30W laser.

  1. Firmware version: SLB out of box
  2. Sender: gSender 1.4.6

First place I’d look is making sure it’s enabled correctly in EEPROM - I’d lean towards it being disabled as an option. We’re going to take a quick tour of the various Spindle settings in the Firmware tool:

The first stop is $395, which is the default spindle. In this case, it should by default be setup to the SLB_SPINDLE option. This both enables SLB_SPINDLE as an option as spindle 0 and sets it as default on power up. You’re fine setting this to SLB_LASER if that’s your only spindle option.

The remainder of the spindle settings are a bit further down in $511-$513. These are all options to enable other spindles options for spindles 1-3.

Make sure if $395 is not SLB_LASER, you set one of spindles 1-3 as SLB_LASER - in this case I have it enabled as Spindle 1. Once applying the firmware changes you need to power cycle the board using the switch as noted in the description.

At this point, reconnecting shows the correct 2 options in the Spindle dropdown:
image

And $spindles in the console also shows the correct output - I have two spindles enabled as options out of the 8 available:

image

1 Like

So glad to not be the only one. I ran into the exact same issue with my MK2 after installing the SLB. I’ll follow instructions from @KGN and update here if I can manage to get it working.

Thanks KGN. This make a lot of sense!
I’m back up and running with confidence.

Ray

3 Likes