Spindle offset incorrect after laser use

I have an offset defined in Gender (v 1.1.7) for using laser. (approx x12 and y7)

Today, after returning to spindle mode after using laser, the offsets on the main Gsender page were huge …like in the region of 1400 for x and 900 for y

This happened repeatedly. It seems.that there is some buffer overflow happening somewhere or that variable initialization is not happening correctly

I have rebooted my machine and will check tomorrow whether this is still happening.

A reboot of my PC and restart of the control board seems to have resolved this issue.

Actually, it has just happened again.
Going from laser to spindle, and back, the offsets are increasing at a huge rate

The offset is changing at a rate of x1791.2 y327.41 each toggle.

In the settings, it is set at 70.51 and 12.89

I managed to get back.to the real 0,0, but the next spindle toolpath went off course by about an inch once it started running (which is bizarre, because it is a job I have run multiple times successfully). The subsequent toolpath ran successfully…but unfortunately too late as the project was already ruined.

@GregM FWIW, Greg, I can duplicate your problem in both gSender and in Edge. If I set an offset and immediately toggle it, it is fine. As soon as I run a file, though, then toggle it, the numbers are off the map. If I disconnect from the Mill, then re-connect, all is well again.

Thanks Grant.
Back to the macros I guess !

@GregM I use macros. I just tried the offset feature to see if I can resolve your problem. Clearly, I can’t. :slightly_frowning_face:

We’ll have a fix for this in the next version. What’s likely happening is your sender is set to MM preferred units, but the file is G20 (inches) - when it sets the offset it’s setting it as 70 inches away instead of 70mm since the offset uses the current unit modal. This also maths out to the numbers you’re seeing. We’ll make sure the offset is set with the correct modal in mind.

@KGN Not to contradict you, Kevin, but this happens with no file loaded.

1 Like

The conversion is correct…you may be onto something.

My Vectric workspace is in inches and Gsender in mm…
perhaps I need to get them into the same units.

My problem is that I can visualize 8x10 inches but not 203 x 254 mm, hence my Vectric units.

But on Gsender, I can visualize moving the bit 5mm but not 0,01968 of an inch…

Contradiction is fine, but this is 100% an issue with unit modal that we handle now. Modal is persistent after the toolpath is run so it doesn’t matter if a file is currently loaded or not. This is reproducible consistently manually in the console with gSender in Metric preferred units:

G21 (we’re in MM on the firmware)
Toggle Laser offset on and off - X and Y values are as expected.
Jog a little as if moved by a toolpath - toggle laser offset on and off - X and Y values are as expected.

G20 (now in inches)
Toggle laser offset on and off - offset is now (70.52, 12.89) inches away - which is (1791.2, 327.41) mm.

G21 (Back to mm)
Toggle laser offset and and off - offset will be (70.52, 12.89) from previous location as expected.

From your verification - this fixes it because the default firmware modal is G21 on connect/soft-reset.

1 Like

@KGN Understood. Tks, Sorry for the confusion I caused @GregM

1 Like

@GregM, just an fyi, you can do your workspace layout in inches if you wish but when it comes to running your toolpaths use the mm post processor instead of inch. Vetric will do the conversion calcs for you.


Thanks! That is good to know !