What are the units for the numbers next to feed and spindle?

Next to the feed overides there are two numbers I do not fully understand. Once upon a time, if old man brain recalls correctly, they displayed the feed in in/min and rpm of spindle.

On your graphic

Feed 1.575
Spindle 1574.803

Where Feed is your feed rate in “Metric (mm/per min)” and spindle is in “RPM”.


Your are telling me that my feed rate is 1.575 mm per minute when it set to and moving at 40 inches/minute (1061mm/min)

1.757 mm/min is impossibly slow.

See my confusion???

Also my RPM is set to 40,000RPM by Vcarve in order to turn on my router control relay.

This does not compute…

As I now know what was set, you are correct, doesn’t make sense

I will go look at mine…


A couple of things, had to give my head a shake!

RPM for dewalt or makita is not controlled. The initial value is picked up from the g-code file.
and as such neither the feed rate nor the cutting speed can be adjusted.

So i don’t understand the graphic either


I know, weird right? All of my settings are for inches as well. This is my fourth CNC machine and my toy that I love but it is different than Mach3. Although, now that I can do tool changes it may become more of a worker and less of a plaything.

Actually, you can adjust feed rate during with the base rate being that which is set (in my case Vcarve).

You are able to do tool changes ? within one file?



1.575 inches per minute is 40 mm per minute. Which CAD program are you using?

When you select your bit before you run your toolpath, you may have mm/min selected for the feed rate so when you output the G-Code in GRBL inch, it will convert.

gSender is only using what is in the G-Code file. Make sure everything is set to the measurement units you prefer (mm or inches) throughout your design, toolpaths, G-Code output AND in your Sender.

Vcarve screen shot

Indeed, I respect unit conversion. However, none of these number correspond to my settings. In Vcarve Pro, my feed rate is set to a base value of 40 in/min and my Speed set to 40,000RPM. I can raise or lower the feed rate in Gsender as the gcode is being executed. The gantry is indeed moving at 40 INCHES per minute not a paltry 40 mm per minute. So again, nothing checks with the charts as we say on submarines.
My question stands: What are the units?
What does it all mean?

Gsender has a tool change feature which will ignore, pause, or excute a pre tool change routine and post tool change routine with user acknowledgement prompts. I use a routine to bring the router to a G55 X0 Y0 position (tool change station) then after the tool is changed a routine to send it back to G54 X0 Y0 (normal work start/center). So far I only use it for indexed end mills that do not require a Z height setting change. I will add that routine when the need or my curiosity arrises.
As for the gcode file, I copy and paste the individual files with an M6 between them in a text editor (Notepad). This tool change routine has performed well so far with ZERO problems. Vcarve will not let me output a single file with multiple tools in gcode because gcode does not do tool changes (unlike Mach3 which lets me tool change like mad). Just output your individual gcodes,

copy n paste with an M6 between them and save as you glorious master multi tooled file.

1 Like

Can you share your gcode?

Also, I have some vectric post processors that will handle tool changes. It seems that vectric points Grbl users to them. There’s not much to it if you want to modify.
Mine also assume homing capabilities.

1 Like

Which one? The code for pre and post tool change or the test file for proofing?

Your gcode file. The one that results in the weird feedrate. Also, what post processor are you using?

Roger all, I thought you were asking about tool change. Here is one.Pocket 1.gcode (746 Bytes)

I did a sample of a few made over the last two years and they all had same weird Feed and Speed numbers.

G20 for sure

Post processor is Gsender
Sience Labs controller Rev 1.3
Vcarve Pro 11 CAD grbl inches output

@whittamps According to that gcode file, your feed rate is 5 inches per minute in Z and 20 inches per minute in Y. You have those commands 8 times in the file, roughly every 5 lines. When you say that you set “it” do 40 inches per minute, where did you set it?

Are you sure that is the file you captured those output values?

You also have your spindle speed set to 400,000 rpm

@NeilFerreri I was so intent on the feed rate that I missed the spindle speed. It doesn’t change the router speed, as you well know, but it does show that he has some settings issues, I think.

1 Like

In Vcarve Pro, see the screen shot above.

@whittamps What’s your $13 setting?