X Axis drops 2mm before and after cutting

Hey All

I am having issues where I go and open a file in gsender that I have used in the past without an issue but now I get it set up and zero everything but when I hit run the Z axis drops 2mm into the cut and travels to the start point only to lift back up and start cutting. It is also finishing a cut and then diving 2mm down and traveling across then material.

I am using the latest Fusion 360 and the latest Gsender. Not sure what is happening, the same file two days ago worked fine. This has happened to multiple files.

I am curious about your issue, especially if you have not re-toolpathed your gcode.

@dburroughs Welcome to the group. I believe that you will find the group here very open to providing advice and help.

To get started on your problem, it would be good to know what CNC machine you using?

Can you recall any changes that you have made in your setup since the file ran successfully?

I have the long mill mk1 30x12. The only change is that gender updated recently, I had only cut maybe 6 things prior to the update as I just got the machine up and going.

I am still having issues. I have reinstalled Gsender but it did not change. When I run a simulation in Fusion360 I am not seeing the tool drop down before and after. Could it just be that I have a setting wrong somewhere?