XYZ Zero Setup not repeatable for presets

I am using a corner jig for material positioning and Sienci probe for zero setup, 2d drawing with Carbide Create! Material size and grid size are the same size, use probe on left front corner of material and select bit size with g-sender, after probe returning to x,y zero. Machining tool path does not correspond with grid drawing. Borders on rectangle cutouts within material design are not equal, drawing calls for 1/4" and y- is .375 ad y+ is .125…I am trying to cut multiple components at once and two sheets are machined and then sandwiched and have multiple cutouts that need to match! Does visualizer coordinates in g-sender have anything to to with this? Pretty longwinded and maybe the answer way easier than my question… Thank you for your time!

Thomas, this kind of sounds like a Carbide Create question. Since, I’ve not used CC much, I can only refer you to that forum: There are many there that can help with that kind of problem.

However, there are others here that can decipher your post.

@Tegbert Welcome to the group. Thomas. As you’ve already seen, there are members here who will quickly step in to offer advice and help with your problems.

I’m not sure that I completely understand your problem, so first off, I have a question. You mention that you are using a corner jig for material positioning. Once you get your material positioned, are you then using the Sienci touch plate to set your zeroes?
Can you explain a bit more what you mean by “grid size”? Where is this grid?
You are stacking two pieces of material on top of one another, then cutting through both, correct? It seems impossible that the top part and the one underneath of it are not the same. How are they different?
I can’t see how the visualizer coordinates in gSender have a part in this. As soon as you are setting XY0 in the same place in gSender as you have set it in CC, you should be fine.
I’m inclined to agree with Tex that this may well be a CC issue, but with more information, we may be able to help.

I too have the same problem of the equal borders in the 2D not translating to the final cutout on the machine. I use Vectric V-Carve Desktop so I don’t think this is a Carbide Create problem. I don’t have an answer for you as I too have been troubleshooting the same issue. I thought I was alone in this so I didn’t reach out here for help. Like you the problem always seems to end up in the Y-Axis with the X-Axis remaining equal and the Y-Axis being off by half.

@braehill If you can post your .crv file, Len, I can run it on my Mill to see if I get the same results, if you like.

I’m not much of a computer guy but I’ll try to upload it here. Hope this works.
Valve Tag Fixture 14OF.crv (239 KB)

This is the simplest file that the problem is obvious. I cut this in 12" x 12" HDPE but it should work in any scrap that you have that size. It’s just a single depth profile cut . Thanks.


Hello Grant, Thank you for your quick response.
I am utilizing touch plate for zero setup and hoping to use preset to be able to repeat setup each time! The grid is the material size selected in Carbide Create drawing to match project material size. After using probe and going to xy zero I have to then make several adjustments to the Y- zero coordinate to make machine cut to match drawing tool paths. The sheets are the same size but one is a contour cut all the way thru material ad the other uses pocket cuts and then both are glued up! Additionally a top piece is cutout in a horizontal flipped position that mates to sandwich components. Alignment very important…

I’m planning on later in-setting aluminum tags in the cut-outs to engrave valve numbers on the tags if that makes sense.

Hello braehill, misery does love company, I have had to massage this setup issue to get usable product each time I run a job! I will continue to try different things and along with communication from the group hopefully we both can resolve this issue!


@braehill I’ll be able to run that later this pm and get back to you.

@braehill I just ran your file in foam, Len and it is perfect. Each of the 52 rectangles is separated in both X and Y by 18". What post processor are you using in VCarve?

@Tegbert I think your problem is beyond my meager abilities, Thomas. I don’t run CC so I have no way of re-creating your issue using your file. I would follow Tex’s advice and try the CC forum.

If you believe that this issue is the Mill itself, I suggest that you raise a support ticket with Sienci. They’ll get you fixed up, I’m sure.

I’m sorry that I could not help.

Just the generic GRBL(inch). The rectangles are spaced correctly when I run it also, but the whole project is always offset in the Y+ by half a bit diameter, in this case 1/8", leaving the bottom border at 3/8" and the top at 1/8". I think is what is happening to Telbert also.

@braehill One thing to consider is that your material is 12" square. However, that is not the material size in VC. In VC, it is 12.25 in X and 11.8132 in Y. Your pockets are centred in the 11.8132 dimension. The perimeter around them is 11.432. Since you set XY0 in the corner and not in the centre, your actual carve will not match the project in terms of it being centred in the material. If you want to use a piece of material different than what you entered in VC, and you want the carve to be centred in the material, you should set XY0 in the centre of the material, not the corner.

1 Like

Sorry to be late, but these kinds of problems are usually because you haven’t got your XY set the way the software is set. You have to really be aware of how your software settings are done before you put a part on the machine. Grant just said that. :smiley:

In software, I hardly never use anything but the lower left corner for my XY zero point. I will change this if I have a lot of components to organize that are round and centered, but before I save for gCode I will switch back to lower left corner.

My lower left corner on the machine is fixed at a predetermined point that I’ve programmed a macro to save to the P1 position. I execute the macro, and I always start there, and never have to set XY zero.

My Z zero is now always at the machine bed, too. My zero block/plate is right near the XY zero point. I’ve programmed another macro to reposition the router over the Z zero block. Then I run the Probe routine to get my Z zero set (to machine bed.) Of course, this Z zero setting is also set in the software so the gCode is produced with that setting.

Remember, the software and machine setups have to match for accurate results.

Thanks for all your responses,
Just as a quick review I am using the lower left corer in CC material setup at startup, and probing with touch plate in lower left corner in g-sender and selecting correct bit size. My design space and material size are the same, I do allow some spacing between components to allow me to cutout individual pieces on a table saw! I am going to try to set CC and g-sender to cut from the center today and see if that helps!

Ok. It doesn’t matter where your XY position is. Just so CC and gSender use the same XY position.

1 Like

@Tegbert To add to what Tex said, given what you are doing, it is also critical that the actual size of your material is the size you input into CC. Since you are flipping one of the pieces of material, if those two dimensions are not the same, it will never line up.

For me, in your case, the puzzling thing is that after you set XY0 with the touchplate, the bit does not return to the corner when you hit return to XY0. Assuming that I am understanding you, that is the main issue to address. As you say, a good test will be to set XY0 in the centre of the material, jog away a bit, then click on return to XY0. If it doesn’t return to the exact spot you set, there are hardware issues to address.

1 Like

I think the original title of my post has led to some confusion, my mistake. It is not a question of being able to set a x,y,z zero when probing, or returning to zero point! The issue is after zeroing the machine the initial cut starting point does not correspond to the CC drawing layout. I tried running program with a center zero and had the same problem if not worse…I am going to switch to USG and see if that helps as it appears it is a software communication issue!