Z-Axis Motor Not Moving Up

I have been looking over various posts and can’t seem to find any solution talk about with this specific issue. Yesterday I finally got everything settled with my Longmill. I had 1 successful cut and had to call it a night. I got up this morning to try a few more cuts and the Z-Axis does not lift unless I support slightly. The best way to describe what I think is happening is that there is too much weight for the motor to pull up. I do have the dust shoe, but I took that for testing and I sam still having issues.

What I have checked:

  • Wiring placement
  • Wiring connection
  • Wiring seated to motor and control box
  • I have taken the router off and it seems to work, but only for a few upward movements
  • Check the eccentric nut and it is loose, but not overly so (I also tried tightening this)
  • Belt tension both tight and slightly less then tight
  • 2 computers running UGS they both have the same results
  • Settings in UGS XY - 10mm | Z - 2mm | Feedrate - 1000

TLDR: The lead screw on z-axis does not move at all when I ask via UGS for a Z+ movement

I have 2 videos uploaded here:

  1. https://streamable.com/k9bc8l
  2. https://streamable.com/ovp3dt

I appreciate any help the community can give!


Two thoughts. 1) how tight is your anti backlash device tightened? Too tight may cause this. 2) unplug the cable from the x-axis stepper motor and plug it into the z-axis stepper, then use UGS to jog the x-axis a few steps. If that works it could be a z-axis cable issue or a controller issue.

This was awesome advice! I did check the anti backlash and it is not tight, but at what I believe is the recommended setup.

I did switch the cables around and got it to work with the X-Axis from the board using the z-wiring.
I also check the x-wiring to the z-motor and that worked from the X connection the the board, but it did not work when connected to the Z connection on the board.

This leads me to believe that the issue is with the Z connection on the board itself.

Check to see how many red LEDs are lit on the controller. There should be 3, one for each of the X, Y and Z axes. If there is only two it could indicate a problem with the Z-axis driver.

Paul sorry for the delayed response! I have 4 lights one for each motor the y has 2. I also checked that they small switches are in the right position as indicated in the setup information.

OK. I guess it doesn’t make a lot of difference. The problem appears to be in the controller. It’s good you checked the dip switches. Did you switch them to their opposite positions and then back to the correct positions? Send an email to the folks at Sienci and explain your situation to make sure they are aware of your problem and get their help.

I will try that and I filled out a form they have on the website that Andy directed another user to fill out but I will send an email to follow up with this thread to see what conclusion we came to.

I was just able to test this out. No such luck with the switches being switched and then put back. I will followup with the Sienci guys and see what my next steps are. I will add what I learn here for anyone experiencing a similar issue.

1 Like

Have a look at my post a while back: Y2 Motor has no torque

May be an issue with the potentiometer.