Z-axis traveling too far, how do you fine tune? Cuts very deep

So I finished the build last night and played with a pen a bit. Now today I’m doing some cutting. But something is wrong with my Z-axis travel distance.

I first tried cutting the sheep sample gcode in a 1/2" board. UGS says it is 9mm of travel so I should have had 3mm+ left over. Instead I have a nice sheep shape in my brand new wasteboard.

I did manually move the bit carefully to the top of the workpiece and did a reset zero, but it still cut too far. Thinking it might be the file, I downloaded the Longmill line text file. It says the cut is about 5mm. Took another piece of 12mm plywood and reset zero to the top side and the lower left corner per the instructions. Fired up the route and let it rip. Right away I could tell it was going way too deep. Sure enough it cut the L and when it went to rapid over to the O it cut diagonally across the board because the bit was too deep.

I haven’t changed any of the machine defaults. I have adjusted the distances in the jog window and have the Z there set to 1 mm but I suspect that is only for jogging anyway?

There is mention in the documentation of checking your machine (with no pointer to where) if are seeing more motion from a distance than you expect, to see if the stepper motor is set to 1/8th of a step. But I can’t determine where it is to look for this. This seems possible. If it is the dip switches, I did inspect them all per the docs during setup but can recheck.

Can any shed any light on where to adjust for this kind of issue?



Hmm, I just went to lift the Z up out of the way so I could get the workpiece out and measure the depth of cut. I noticed that sometimes when I advance the Z it isn’t moving. The belt is turning but the lead screw doesn’t always turn. Ugh.

Now where the heck did I put that tiny allen key that is included for adjusting those? Not in the bag with the other keys I have, gah. Thought I put it in there… Anyone know what size that is?


Found an allen wrench in my set. Hopefully I can also find the included one soon. Tightened the double set screws on the lead screw end on the Z and I seem to be back in business. I am bit worried about constantly having to chase these set screws. Is that projection or do they need to be checked before almost every run?

Also, and maybe it’s my lack of experience with UGS, but it does not seem to be using the zero position I set. I tried to set zero and run in the sheep nd it keeps shifting over and up. I thought you were supposed to position it on the center you wanted and then just run it? Also, do you have to start a job from the bit being at zero Z height? I’m used to being able to have the height anywhere and run and it should go to the correct height to cut. It appears if I lift the Z to jog it and then run the code, it runs in the air?


Waiting for any reply to this one, experiencing a similar problem.

Ok I appear to have a good cut on the sheep after the Z axis adjustment. But the Reset to Zero issue is a huge problem. I need to figure that one out. I am using the recommended August 2019 build off UGS.


Jeff: Once you set your xyz0 positions, you can jog the machine to wherever you like. When you run the gcode, it will first move the router to the xyz0 position you set. That has been my experience anyway. Just be sure that UGS shows xyz at 0 after you have set them all.

As for the set screws, I’ve checked them all a couple of times since first running the Mill and they have not loosened at all.

Hi Grant,

Your description of zeroing is what I would have expected but I think maybe that CNC sheep file has something odd about it. Not sure. I was able to set zero normally and cut the Longmill text example and my Z axis seems ok now.

Thanks for the feedback on the set screw adjustment interval.

Off to swear at F360 and try and remember how to do a project. It’s been a while and I have to relearn it each time. Impressive software but the learning curve is dreadful…


Jeff, I think many of us have had some slippage due to a loose screw. Screw connections that are made up the first time are notorious for loosening. That’s why before I put a recently completed car on the road it gets a complete inspection. I traced my troubles to screws that I meant to go back and check before I went live and forgot, and some were just not tightened sufficiently in the first place. The locking collars on the Y axis bit me good once, so l checked all of the screw collars and motor couplers, and have not had any more trouble. It is certainly a good idea to check them once in a while, but I don’t think you need to do more than an occasional check. If you’re really concerned, put a drop of blue , NOT RED, Threadlocker on the screws.

Have fun, stay safe.


Wait, are we still talking about Longmills? :slight_smile: At least in my case I think that may apply to a broad range of situations…

Good advice on the fact that the first bite doesn’t always cut it. I’m really glad I ran a few simple test cuts in old off-cuts because I definitely got some surprises. The Z-slippage is probably the most dangerous because it can plunge the collet nut in to the workpiece and the force of the machine dragging it can do some damage. Thankfully the worst slip I had was in to a foam test piece so no harm there.

I believe I have some blue threadlocker in my toolchest from some car work. If I have any more issues I’ll dig out out. Good suggestion.

I see a Corvette logo in your avatar there. Are you a fan of the new C8? It’s growing on me.


@chrismakesstuff Continuing in the theme of making small suggestions to improve the (already excellent) Longmill experience - it occured to me that if you switched to a nice hard foam rectangle for the “top” of the foam padding around the Longboard for shipping, then you could revise the CNC Sheep starter project to be optimized for that dimension and thickness of foam and the first test cut people do could be in that foam. So it’s recycling (upcycling?) built right in. I tried to use the soft foam but it went badly as you might expect… That little change would ensure people had the right size and depth of work piece and a project ready to go. Might also be a good idea to move zero to one of the corners to make it easier for newbies to zero out on the workpiece. Guessing center is a bit more challenging…



Jeff, as I was writing that it occurred to me that both meanings could be true.

My newest Corvette is a 2015 Z51. Far and away better than all previous 'Vettes in all respects. I’ve driven a couple C8s and it’s very impressive. The ride and driver positioning are different than even the C7 and I’m not especially fond of them. Maybe I’m too old, or too traditional.


I believe this to be true, and it should probably be mentioned more prominently - If you hit the end of the travel on one or more axis and over-drive the motor then you will loose your accurate coordinate position in UGS.

I believe this is the reason I had some unexpected results in a fairly precision drilling/cutting operation last night and I couldn’t figure out what happened between tool changes as the goal was to use the identical zero. I think I may have bumped up against the limit of travel as I was cutting a piece larger than the work area so was using the entire work area.

Causing a dislocation to the zero settings could also present as mistakes in the Z-axis depth of cut, is why I’m adding the note to the thread if the Z is reset.

Also, I’m starting to think that the $1 = 255 change to force power to the motors even when idle is possibly a good idea, as I had some other slippage on my Z last night that I couldn’t easily explain… A bit frustrating to have to turn it on and off each time you run UGS. I need to learn about Macros…


I can see your confusion here @jwoody18, the CNSheep file has a code quip that I put it it which sets it’s own work-piece position after being run, thus it will always reset the zero that you initially set.

I think I didn’t fully think this through when I made the change, I think I’ve got an idea on how to fix it though. I’ve uploaded a new version of the file below, would you be able to give it a try for me and let me know what your results are?

CNSheep_Foam.nc (128.3 KB)

Also, I really like your idea of cutting the sheet into the pakaging foam. Good news that the new control box packaging has higher density foam! I’ll put it on my list and give it a try and if all goes well I’ll add an update to the website to make that same recommendation :slight_smile:

Will give it a try when I am in the shop later today.

Hello. I’m new here too and getting frustrated. I use Fusion 360 (beginner) and get it all over to UGS. I zero with the touchplate, then when I play the file, the Z axis goes way too high and tries to cut in the air above the board. It did the same thing with the sheep file and the Longmill file, so it can’t be Fusion 360. It must be UGS? How do I fix that? I would think that after zeroing, it would set that position as the very top of the wood.

Are you using the updated GRBL post processor for Fusion 360? I downloaded and installed and selected that, and had to edit the config a bit (can’t remember which parts at the moment) and it seems to be working ok for me now. I did see something similar to what you are describing before I got the GRBL post processor.

I found it here: https://forums.autodesk.com/t5/fusion-360-manufacture/looking-for-a-working-correct-post-processor-for-grbl/td-p/8713533

After running the Z zero remove the touch plate. Hit “Return To Zero”. The bit should move back down to the material surface. DO NOT hit “Reset Zero”. If you want to test just remove the touch plate and your material and see if the bit moves back down to where the material would have been. Good luck.

I tried this. It did not solve the problem.

I run the xyz set. When I select Return to Zero, it does go to the bottom left as I expect and touches the wood. It is only after I play the file that it moves too far back up and doesn’t reach the wood while cutting.

Can you take a picture of your numbers that you put into ugs for the touch plate? All 4 settings. XYZ, XY, Z and Settings.