gSender Wish List and List of Active Bugs

Hi everyone!

This week there are a lot of exciting advancements that are happening on the development side of things for gSender that will culminate in the release of 0.7.0 this Friday. I thought that I’d take the time this week to go through all the current posts in the gSender category and either close them if they’ve been solved or summarize them if they’re still open. I’ll be pinning this thread to the top of the category to act as a summary of essentially Where is gSender currently at

I hope it will be a good central location to summarize the feedback that I’m seeing for everyone as well as provide an easy spot for newcomers to reference if they’re considering picking up gSender. If you see anything here and have experienced it as well, please vote on it as well as comment on your own experience to help narrow down where opinions and experiences lay.

So here we go:

gSender Wish list

  • Manual value entry for X, Y, and Z locations
  • Center-finding probe option for gSender
  • Ability to toggle off start and end gcode
  • G-code editor
  • In-app counter that informs you on hours of machine operation (actual running jobs) to help time upkeep, maintenance, and just for fun :slight_smile:
  • Configuration Wizard

0 voters


  • Jogging on machine pause (e.g. for tool changing)
  • Ras Pi headless support
  • Show the path of the loaded file (maybe a tool-tip type popup?)
  • Option to reload the same file if it’s being iterated on
  • Make GOTO configurable to be XY or XYZ

gSender Currently known bugs

  • Freezing interface on longer / larger jobs
  • gSender disconnects and buttons are greyed out at end of job

0 voters

To note, this post will continue to go through changes throughout the week so please check back to vote again if more items appear that you also agree with or have experienced.

The reason why some features are not mentioned (e.g. start from line, joystick control) are because they might just be nearly complete :wink:

1 Like

There are some additional things I’m adding to my original post but as it turns out I can’t modify the poll once I’ve posted it. I suppose voice your support in the thread so I can know if people are interested in the features that they can’t vote for :slight_smile:

Honestly there’s so many features that I would like to see would take all day to go through them

And we’re just a Motley Crue of testers who want specifics this might be something to post in the Facebook groups because there’s so many more users in that circle

Maybe even have one of the website developers create a poll that you can maintain on the site as well as deposit wish list items

1 Like

That’s a fair point Stephen. I think your feedback is still very handy because I think it’ll help us to track the more advanced features being requested for gSender. From what I can tell, as of now if we can iron out some remaining bugs: the vast majority of users are quite happy with the current feature set of gSender.

What other features did you have in mind?

I would love to see an area where macros can be placed and shared.

  1. I would like to see a feature or macro that will allow me to measure the thickness or distance with the probe block.

  2. I would like to finish areas with one bit and other parts with a different bit. I would like to see a way to to maintain my Zero ref. while changing bits easily.

@CluelessJoe Do you mean that you would like to see an area in the forum where users could share their macros with other users?

  1. What are you trying to measure the thickness of? Also, what distance are you trying to measure?

  2. gSender does not lose the initial XY0 at the end of a tool path. So, you can jog to wherever you like, change the bit, reset Z0 to accommodate the new bit length, then send the machine back to the original XY0. Is this what you are asking for or am I misunderstanding your request?

A post was split to a new topic: CNC Ideas and improvements

@CluelessJoe I think the clarifying questions that @gwilki asked I would ask the same because I don’t think I understand your original comment.

@Menglor Great to see a nice feedback list, it’s always welcome :slight_smile: As far as gSender related suggestions, your idea on a maintenance feature is a nifty one, as well as loading multiple files, and tiling. Headless we’ll be continuing to work on as well. The rest are certainly more hardware related but are great concepts: some which we’re trying to address soon and others which we’re batting around in our heads still.

If you have anything else come to mind I’m always open to listen :call_me_hand:

4 posts were split to a new topic: Probing ability on LongMill / gSender?

I have just been using the version 0.7 update, great to see some of the bugs addressed but I still have one that I can not get around. I have a home made GRBL CNC it works well with UGS and has been doing so for the last 12 months.
I have Limits and Homing enabled in my GRBL settings, but I find that if I should inadvertently hit a limit then the Jog command continues (although GRBL shuts down the travel) and I can not stop it with the centre stop button on the screen.
Also the only way to get out of this is to disconnect from the computer then reconnect and jog away from the switch. As GRBL looks at any change of state on the limit switch input, ie high to low or low to high it shuts down again when I clear the limit switch.
a button pops up when I complete this operation asking me to reset and re-home. Maybe this pop up could appear when you hit the limit switch? Look forward to hearing any comments, or workarounds. Oh and I do have the end stops enabled in the settings

Hi Biffo, thanks for the feedback on the latest version. I’ll have to re-read you comment a handful more times since I’m not understanding exactly what’s going on, but certainly seems that something is going wrong with limit sensing and jogging. If you happen to have any more info it would be appreciated :+1:

hi Chris, this is not just on 0.7 it also happens on the other versions.
I was setting up the limits to check what the max travel on x and y was.
to do this I jogged to the limit switch to record the x axis value.
This then causes to GRBL to shut down and stop travel. but the green jogging command is still active on the screen, that is it does not go to Idle.
The only way to reset this is to disconnect from the computer and then reconnect. It is then that a popup appears to reset machine and then re-home.
The second part is normal and happens with UGS as well in that GRBL has already sensed a change in state of the limit switch low to high, and now when I jog off the limit switch GRBL now sees a state change from high to low and shuts down the GRBL again. This is a GRBL problem, but once again the only way out of the lockup from Gsender requires me to disconnect once again and re home the machine. There is no reset facility available until I reconnect to computer
hope that makes it a bit clearer

1 Like

If you would like dump the dollar sign? And get all the settings to display and post them

I have limit switches set up I just don’t know if they’re set up the same way as yours

I can also post mine if you want to take a look at what my settings are

And if you give me the a step-by-step on what you’re doing I’ll try it online as well

Not to diminish what you’re saying but I haven’t had anything problems with my limit switches

But you comment that you have your limit and homing switches set up I think I just have the homing stuff stuff set so there may be a setting you’re running I’m not

Maybe @chrismakesstuff can identify the differences between why here settings on my settings are and that can help them

My settings with a WORKING homing setup, I have never had problems

client $$
$0=10 (Step pulse time, μs)
$1=255 (Step idle delay, ms)
$2=1 (Step pulse invert, mask)
$3=5 (Step direction invert, mask)
$4=1 (Invert step enable pin, boolean)
$5=1 (Invert limit pins, boolean)
$6=0 (Invert probe pin, boolean)
$10=1 (Status report options, mask)
$11=0.010 (Junction deviation, mm)
$12=0.002 (Arc tolerance, mm)
$13=0 (Report in inches, boolean)
$20=0 (Soft limits enable, boolean)
$21=0 (Hard limits enable, boolean)
$22=1 (Homing cycle enable, boolean)
$23=3 (Homing direction invert, mask)
$24=100.000 (Homing locate feed rate, mm/min)
$25=1500.000 (Homing search seek rate, mm/min)
$26=250 (Homing switch debounce delay, ms)
$27=4.000 (Homing switch pull-off distance, mm)
$30=30000 (Maximum spindle speed, rpm)
$31=0 (Minimum spindle speed, rpm)
$32=0 (Laser-mode enable, boolean)
$100=200.000 (X-axis travel resolution, step/mm)
$101=200.000 (Y-axis travel resolution, step/mm)
$102=200.000 (Z-axis travel resolution, step/mm)
$110=4000.000 (X-axis maximum rate, mm/min)
$111=4000.000 (Y-axis maximum rate, mm/min)
$112=3000.000 (Z-axis maximum rate, mm/min)
$120=750.000 (X-axis acceleration, mm/sec^2)
$121=750.000 (Y-axis acceleration, mm/sec^2)
$122=500.000 (Z-axis acceleration, mm/sec^2)
$130=812.000 (X-axis maximum travel, mm)
$131=812.000 (Y-axis maximum travel, mm)
$132=105.000 (Z-axis maximum travel, mm)

FYI CTRL C isnt working again

Hi Menglor
my settings differ only in the $21 =1
I dont have a problem with the limits per se but how Gsender interprets them., and how I can reset them. In UGS they have a reset button on screen all the time and this does the job. On Gsender the reset button only comes on the screen as a pop up when you re-connect

Can you give me a detailed description of what you’re doing to reproduce the problem and I can try and reproduce it

Ok Here Goes

I send the x carriage towards the limit using the jog button. I keep going until the limit switch stops the travel.
you will see that the Jog command is still active ( top left hand corner of the screen)
If you hit the stop jog command in the centre of the jog buttons, nothing happens. GRBL has at this time stopped the drive and the motor is not driving.
The system is now effectively locked up.
The only way to reset is to disconnect from the computer and reconnect again.
a popup appears asking to reset after the computer has connected.
now when you use the jog keys to come off the switch, the switch resets, but this stops the GRBL again.
Once more you have to disconnect from the computer and reconnect again to get the reset button and the home command.
then its back to normal.
how’s that

one more thing,
If the pop up would appear once the limit switch had been activated, this would solve the problem, and you would not have to disconnect from the computer.

I can’t seem to get my lazy ass out of bed this morning… I’ve been up all night with a sick dog so I’m just not feeling like moving

So I haven’t tried what you’ve tried

But Chris just posted some changes to the behavior coming back from sleep mode in version 7.1

Which makes me wonder if the behavior you’re seeing is the same thing I saw when it came back from sleep

I’m wondering if you could retry your behavior in 7.1 and see if it’s still a problem