I’m beyond frustrated

Hey guys and gals. I can’t seem to get anywhere with gsender. I hooked up my wife’s lap top and downloaded g sender on it and everything worked great. I got a desktop as she is always using her lap to and for the life of me I can’t get this thing to connect no matter what. I followed all the exact same steps as the lap top and no luck. I went down a rabbit hole of trying to get it to connect and it just won’t. On the drop down box I can get it connected (so it says) but on the screen it doesn’t say idle. It says disconnected. I’m at a lose with this thing. Honestly I’m to the point I need someone to go on team viewer maybe and see what I’m doing wrong. Third day with zero success. Thanks

@wpgstreetglide Mark: What OS are you running on the desktop? Is it the same as the laptop?

1 Like

I’m running windows 7 on the desktop and 10 on the lap top. I was thinking about loading 10 onto the desk top if it’s possible

@wpgstreetglide Here are some initial things that you can look at, in no particular order.

  1. make sure that you have installed the correct “bitness” on your desktop. Meaning, you installed a 32 bit gSender if the OS is 32 bit and 64 bit otherwise

  2. Try a different USB cable.

  3. In device manager, make sure that windows is setting the com port that the controller is using.

  4. Ensure that that com port’s baud rate is set to 115200, and that the comm rate is gS is set to the same speed

  5. While this will not prevent gS from connecting to the controller, while you are in control panel, make sure all power saving setting are turned off, including those available to USB ports.

1 Like

Ok. I believe for the most part I have all the setting correct but I will definitely double check. I just find it odd that it all loaded up on the lap top like a breeze lol. Thanks for the help

I couldn’t get my Win 7 laptop to work, did all the Arduino stuff but just never got the drivers to install correctly. My Win 10 LT connected no problem, but I didn’t want to use it regularly, so went and bought a new LT. Didn’t realize it had Win 11 installed until I was setting it up (all pkg & flyers said Win 10). Although I get it to connect, it randomly disconnects ALL the time. But, my Win 10 disconnects, too, just less often and not as quick.

1 Like

This is not an expected behaviour. It is not possible to work under those conditions. It is worth looking at what the conditions are. If the hardware is significantly different from each other, you may be attempting the impossible. At the very least, the devices should both run the same software or you cannot eliminate the differences as being one of the root causes.

Why not? What is preventing the correct installation of drivers? It is tough to make something work if it incorrectly installed. Can you reinstall everything from scratch?

Can you downgrade it to run Win10? You say the win10 LT “connected no problem” but later you said “My Win 10 disconnects too, just less often and not as quick”.

All of your hardware should run the same correctly installed OS so that you can troubleshoot easily.
Check your CNC machine is not suffering from electro-mechanical interference (EMI). This is randomly generated currents that can halt a machine in its tracks. Sources of EMI include shop vacuum suction producing static electricity currents that will halt the machine. Power leads running too close to stepper motor leads and so on. Separating power leads from all others is a good policy and keeping them separated by say… 6 inches will eliminate a lot of EMI based issues. Humidity, dry air, heat can all contribute. It is a very large subject.

Start out with an easy base point. Every computer device should, ideally, be running the same OS. Connect each one separately and test for EMI. Note all of the conditions which were in use and led to failure. Try to replicate them until you home in on the reason for unwanted stoppages. Look at your cable routing and see if you can create a degree of separation between power cables and the rest. Keep a note of what you did that was effective in restarting the CNC machine. I don’t think it is impossible to address these issues but you could give yourself a better opportunity to do so if you make everything you have been doing a little more consistent.

EDIT: Spelling and grammar

Yeah that’s what I’m finding out. I’m pretty frustrated because I bought this computer after reading that the Longmill was compatible with windows 7 only to find out it really isn’t. Looks like I’ll have to go out and spend more money on another computer with windows 10 or purchase windows 10. My lap top running windows 10 hooks to it perfect but I can’t use it in that environment as it’s my wife’s for work

@wpgstreetglide Mark. gSender will run under windows 7. I know this for sure as that is what I was running on my old, beat up, shop PC. I have recently finally upgraded it to win 10, but it ran gSender without issues under 7 since the first days of gS beta.

@jepho We seem to have two owners on this thread with similar, but different problems.

@wpgstreetglide Mark cannot get win7 to work, but can use win10.

@DaWoodster Ken could not get the arduino drivers to load on a win7 laptop. He did get them to load on a win10 laptop, but the connection dropped randomly, and it is worse under win11 (which, in reality is in beta so much could yet change :grinning:)

To both Ken and Mark, I can say that, in my experience, gS will run fine under either win7 or 10. I have no experience with win11, although I do know from other windows forums that there are lots of issues with win11 and drivers. Clearly, YMMV, but I would suggest that, before you buy more hardware, or change OS, you look to other solutions to your problems. For example, there are many threads on here about disconnects and freezing. Just MHO.

1 Like

Indeed, Grant.

I tossed a few ideas into the mix… with the hope that something will click and make sense. All problems are amenable to resolution but not usually when looking at an issue in isolation. To that end, I would always try to understand what is known… and then deal with the unknown as it occurs.

Standardising techniques , methods and routines frequently is a step in the right direction. Following them up with close observation and then testing… this usually leads to the solution becoming known.

1 Like

I’ve gone through the different threads and suggestions with no luck. My windows seven also won’t load the drivers. But I hook up my windows 10 and within minutes I can operate the machine with zero issues. I’m going to borrow a buddies computer which is also on 10 and try that cause I’m ready to take my current computer running windows 7 for a quad ride haha. Spent so much of my time trying to sort it out.

@wpgstreetglide I can sympathize. Just for my info, when you connect your Mill controller and start win7, does it even try to load the appropriate drivers? It’s weird that it will not.

If you are relying on win7 to do its thing and it is not, another option is to go onto the Arduino site and download their drivers. They are written for win7 and above, and, FWIW, have never failed for me.

1 Like

@wpgstreetglide Did you get things working to your satisfaction, Mark?

I’ll be going into the shop after work again tonight to give it a shot again. I was out of town most of sat and Sunday. Thanks for all the input and help it’s greatly appreciated. I’ll update on here if and when I get it going. Thanks again

1 Like

Made a bit of head way tonight. Now I have the arduino driver loaded and my computer no longer shows an exclamation point on it. When I go over to Gsender to try and connect it shows connection error on com 4 ( which I confirmed is correct). I tried different ports with the same results. Tried to the windows 10 lap top and connected right away again.

I’m pretty sure there must be something very small preventing me from getting it to connect.

But I’m getting behind on customer orders due to the time I’ve invested into this. so unfortunately this may have to go on the back burner as the CNC mounts to my assembly table. I also have customers wanting custom signs so this is pretty frustrating.

@wpgstreetglide A very quick check will be to ensure that your communication speed in windows and in gSender are the same. The default is 115200.

If that’s not the issue, there are other things you can try when you have more time.

Good morning Grant, just to wade in here, what jepho said was technically right. I was having a lot of random stoppages until it was pointed out that EMI and power surges could be part of the problem. Arduino controllers seem to be sensitive to the stuff. Everytime another machine would start up or the vacuum system would come on, the CNC would stall. I purchased a high end surge protector for my machine and PC and the stalling seems to have diminished. It now only happens occasionally on long jobs.

I set the USB port speed to 115200 and also Gsender to 115200 but it didn’t change the outcome.

I spoke with the wife ( head of operations in life and business haha) last night and she said I’m ok time wise to work on it for the next two evenings so I’m going to make a push to get it up and going tonight. I’m thinking about uninstalling everything and starting back at square one.

One question, do I have to “wipe” the controller itself if I do this ? I am not sure if the arduino board itself stores software or if it’s the program that does?

I just want to also take a minute and thank this community. Everyone that has had input is appreciated especially you Grant. I appreciate the time you’re taking out of your day to try and help me and other members out.

Just getting the port up situation sorted last night has gave me some drive to figure it out. Once my little man goes down for the night I’m going to try again

Thanks again,

@wpgstreetglide You’re welcome, Mark. I expect that I’m damned near as frustrated with this as you are.

Since you can take some time, I would suggest that your next move is to reflash the controller. Basically, what you are asking about. So, assuming for the moment that gS can talk to the controller, you can use the re-flash module to reset everything. Follow the instructions on the sienci site carefully. There are two steps. One does the actual flash and the second resets everything to the defaults.

Here are the steps from the sienci site:

Firmware Tool

Firmware is pre-installed into each Arduino on the Longboard, along with the custom EEPROM settings, so typically users do not need to access the ‘Firmware’ tool at the top of the screen. However, if necessary, the ‘Firmware’ tool can be utilized to restore everything to factory settings or make other machine alterations. Once you press ‘Firmware’ a dialog box will open, showing the EEPROM settings that are on the Arduino.

‘Flash GRBL’ will reset your firmware back to its default configuration

‘Restore Defaults’ will bring back your machine defaults in case they’ve somehow been altered or wiped