MillOne : skipping/error/offset during milling

Hi there, i just got my millone (used). All seems well and I dismantled the whole thing and rebuilt to ensure the wheels are set correctly, backlash nuts are correct etc. I’m using kiri:moto. So all is well and I’m moving forward. But i have two errors that keep creeping up on me. . Can you suggest what is happening?
generally I’m using a 1/16th or 1/8th end mill on 2 - 6mm mdf or ply. Speeds are 20k and feeds around 700. I’m cutting out a faceplate for a set of potentiometer and switch controls on a synthesiser faceplate. So around 30 different circular and rectangular voids to cut. I’m using “rough” in Kiri, with a 0.5 step and a 2mm step down. With “inside only” and “clear faces” and “clear voids”. Holding the work with either carpet tape or hot glue gun. Generally there will be two passes at 2mm increment depth.

  1. 2/3rds or so through the run the cnc will make a very soft knock sound (not like the hitting max x/y clatter sound) and then the cnc will become offset by around 3mm on every Y position. The piece is not near the bounds of the platform so i am not hitting max x/y. There is no error reported on the UGS console. It generally happens on the second depth pass although i have also tried “depth first” and it still happens. It doesn’t always happen, but more often than not. I can’t see the piece moving/slipping/ nor hitting bounds at any point. This is of course a pretty big issue as it destroys the usefulness of the piece. I could split the work into 2-3 distinct gs files and run them in series. I was thinking maybe a buffer overflow error , or the USB chokes, any thoughts?
  2. This one is minor and more for me to understand why. So same set up as above. On the rectangular voids (they are all 15mm by 5mm by 4mm deep) I’m getting a perfect cut except one corner has a round cut that extends outside the rectangle by about 25% the milling bit diameter. So imagine a rectangle with the top left corner having a small circle extending outside the rectangle. It looks to me like it’s where the bit enters/exits the initial cut so I think I have something setup wrong in kiri:modo. IIs this caused by a climbing/non-climbing cut? Thoughts?

Thanks, it’s a great machine.


@tuejan Welcome to the group Nik.

I have no experience at all with Kirimoto, but I’m confident someone here may be able to address your software questions.

In terms of the UGS/hardware issues, I’ll start with some questions, then maybe, with the help of others here, we’ll be able to get you fixed up:

  1. What version of UGS are you running?

  2. Do the knocking sound happen on other files, too, or just this one?

  3. What OS are you running on the PC that controls the Mill?

  1. Version 2.0.7
  2. I’m currently only running this. However I have many different versions of this file as I adjust parameters etc and it happens in all of them. I did some v carve of text using carbide and I didn’t get any errors in those files
  3. Windows 10 , the most recently released build, everything is up to date.



after reading this “keep-having-x-axis-wander-in-positive-direction-mid-cut” i’m going with the idea that it’s UGS introducing this error. So i’m going to try cncJS

So with cncjs I can see that the chide sent in getting in front of the spindle. So I’m doing a manual pause energy 8 mins or so. That fixes the offset problem. So it’s likely some buffer issue that get too full ,then rejects some instructions then picks up. A pain to have to manually stop the job.
Maybe some firmware issue on the arduino.

The other error I’m going to add a picture. I think I have a setting wrong.

@tuejan Nik: Are you running the file from a USB stick? If so, copy it to the hard drive of the connected PC and try that.
Also, make sure in Windows 10 that you turn off all power saving settings, particularly the one that reduces power the USB ports.

re: your picture. What is your plunge rate and depth?

I always move the nc file onto the laptop. Stepover is .5 (50%) and step down is 2mm. overall depth of piece is 6mm (well nominal 1/4" hardboard). Z zero is set at about 0.5mm above stock. I was thinking climb cuts etc. The Makita turns clockwise (looking from the top down) and the cuts are all clockwise. I should say that this image is X plane top to bottom, Y plane left to right, sorry. When i watch closely i can see that on each concentric cut, each time the cut moves into the next inner cut (that would be also on those rounded out corners) it slightly moves out. Everything is tight, there is no play in any axis and $1 = 255. You can see that the round cuts also have an entrance mark. However it’s fair to say that the round holes are only 7mm diameter, with a 2mm diameter bit, so maybe i am expecting too much. Also, honestly it’s probably faster and easier to have the cnc mark the round holes but use the drill press to cut them.

But i hate not understanding why!

@tuejan I don’t think that you are asking too much at all. I had a similar problem when cutting out box lids. I could always see when the next step down occurred. Two things fixed it. Now, I am using VCarvePro, so you may need to look at different options. First, ramp in your cuts. That will remove any one spot where your bit is plunging straight down. Second, is to do a final pass at full depth. I don’t know how Kiri does this, if it does. In VCP, I can tell it to leave .001" for example for a final cut. So, to use your pics, I ramp into the cut for the rectangle, but the outside dimension of the rectangle is .001" too small. Then, when the full depth has been reached, a final cut is done, but at full depth… Since the cut is only .001", the bit can handle full depth, and it removes any “steps” that show in the other cuts.

In terms of your hardware or sending issues, it seems that you have issues with both UGS and CNCjs. This would lead me to believe that it’s hardware related. I’ll look back on some other threads and ponder this more. I’m afraid that, right now, I have no advice. Maybe others here will chime in with ideas.

Edit: Make sure that the X gantry is moving perpendicular to the Y rails when you are doing your setup. If the X gantry is skewed at all, your Y rails will not be parallel. (Maybe, too obvious??)

Thanks for all the info folks, new to this but trying to ramp up quickly. So I spent a few days just learning Fusion 360 and cncjs. I’ve gotten rid of the weird skipping, I think it was screen off power function. I’ve also got rid of 90% of the weird corner issues where the bit seems to go to far into the corner. This “fixed” when I moved from Kiri:Modo to Fusion 360.

So the rectangular pockets are now totally fine. The circular pockets (again I realise I should be using a drill for this part) are still not great. They are eccentric, around a 0.4mm difference. The longest the “circle” diameter is, is always on the -X-Y to +X+Y or diagonally. Which made me think that maybe the X and Y motors are not responding the same exactly. So i checked the firmware gcode and everything is exactly the same for X and Y. So I checked the tightness of the V wheels ( this is a MillOne) and they are all tight. I checked the couplers, tight. I looked at the squareness of the X axis to the Y axis (but I’m not sure exactly how to check this so i measure the gap from the side wall of the mill to the Y axis at the front and back most travel of the X axis and it was the same value so I guess it’s perpendicular.

Next I moved the X motor to the Y axis and vice versa. The idea being that if one motor is weaker or more worn than the other that this will change the -direction of the circle eccentricity. But it didn’t. While they were swapped I also checked the two bearings, they both moved freely.

I also tried moving from a 1/8th shaft 1/16th end mill to a 1/8th shaft 1/8th end mill (actually they are metric but close enough). No real difference I could see.

Maybe I swap the X and Y drivers in the shield? Or the X & Y V channel and lead screws. Also maybe the X & Y backlash nut are incorrect (not the same ones as the LongMill ones, rather just two ended brass nuts with spring between)


So this is where I am at. These are just test holes with lots of different parameters in Fusion 360, but using 2d pocket and 2d adaptive. Spindle is 20k, feed is from 700mm to 300mm. Step over is from 1.5mm down to .375mm. Multi depth on and off. Some are 1/6th bit some are 1/8th. The square pocket is me testing if the spindle is orthogonal to the XY plane. I’m guessing I do this by cutting a face with a 1/8th end mill set at a just under 1/8th offset. Then it mills the pocket around 1mm deep on both the X and Y axis. If the mill is not Z is not orthoganal then I should see either/or lines going along X or Y. But i see almost nothing.

PS… the work piece is screwed to the wasteboard.

Hoping someone can help me with this non circular circles issue. So today I:

  • Removed the backlash nuts totally. no change
  • Took off all the wheels, check for damage, cleaned, checked bearings rotated and washers were correct side. Re attached and reset wheels so that can’t move with fingers but can rotate lead screw with fingers. no change
  • Checked and cleaned all edges of gantry angle structure.
  • Tightened every bolt
  • Removed makita router, checked diameter, checked diameter of printed holder and noticed it wasn’t quit perfect. Adjusted(filed) the clamp areas on the printed holder so the holder is tighter on the makita. This fixed the weird eccentricity from top left (in image in previous post) to bottom right.
  • Tried all my different bits. Currently using an Amano 1/4th shaft, 1/8th end mill.
  • Checked for step accuracy. Across 140mm I’m losing around 0.5mm to 0.25mm, slightly less on the Y than X. So I set this so that a jog of 140mm in cncJS lands the bit centre at exactly 140mm. or as accurately as my digital calipers will measure.
    *Finally I tried a ton of different toolpath options in Fusion 360, mainly 2D Pocket both with and without finishing passes and spring pass.

Not really much further forward. I have a slightly better hole that is typically widest on the diagonals , so measuring from -X-Y to +X+Y or -X+Y to +X-Y. So it’s sort of squared slightly. How slightly, widest measurement on a 10mm circular pocket is around 10.03mm to 10.25mm and narrowest (top to bottom or left to right measurement) is around 9.75mm to 9.95mm. I’d like to get the variance to around <0.2mm.

It’s interesting that widest is on the diagonals always. The diagonals are the widest (best) part of the circle as they are around 10.00mm which means the top to bottom and left to right areas are the worst. This would be (think 12o’clock 3, 6, 9) the place were one or the other stepper motor was changing direction. I assume this would be the largest load asked from the power supply (24v 5A, and motors are 1.7A). Wonder is the power supply is not working as intended?

Couple things left to check. I’ll swap the cables to the motors and the drivers, I might pickup a new power supply.

So continuing along the exploration here. Couple of new things I’ve done.

  1. Bought and used a dial indicator to more precisely measure X,Y,Z movement and recalibrated it all. It’s now within a 0.1mm on all axis across 10mm.

  2. Replaced the standard 5A power supply with a new 6A power supply.

  3. Installed new stepper drivers in the X and Y axis shield board.

I have a full new arduino , and shield shipping in a couple of days.

I don’t think there is anything else I can change at this point from a hardware point of view. So next i’ll be going through software and checking out different gcode senders.


So after all the changes I made that for sure made the machine more accurate and made me totally understand the machine and how to dissassemble etc, and get a great view of the different software available, and learn Fusion 360, I finally got a solution.

As I had flats in the circular holes at 4 points on the circle I had guessed it was torque/power related. That being where the system uses the most power as one axis is constantly moving and the other has to change direction (think from 2 to 4 o’clock on the circle) , not the motors, not the stepper drivers, not the cables, not the power supply, not the backlash nuts… it turned out to be the delrin v wheels being too tight.

What i did yesterday was do the opposite of what i had been doing, instead of tightening everything up more and more, I went around the machine and just loosed stuff. Immediately the machine started to make way better circles.

So this is what I had…

And this is what I have now

The outer rect is 70mm and 3mm width cut. These are using a flat end upcut 1.88mm bit. The inner circle wall is 1mm thick. I can still see a flat spot on the right wall of the second smallest circle, and a slight notch in the same place in that inner circle wall.The inner circle is 10mm wide

The measurements are 70.25mm X 70.19mmY and the inner wall is ~1.02mm. The cuts are around 3.15mm wide. The inner circle measured 10.12mm dia So pretty accurate. I found a drill with a 10mm shank and it was a decent fit into the 10 mill hole.

If you read these articles then thanks. If you are like me and are buying a used Sienci MillOne then be confident that they are fun and easy to work with, really interesting to understand, and can be pretty accurate.