More & More X-Axis Issues

When I first turn the machine Long Mill 30X30, every thing seems to work, however the X-Axis stops moving completely using UGS, I Can hear the motor clunk a little when I try to jog it but won’t work at all after it stops. Next day all seems well but again it will stop, I am new, I have looked but don’t seem to locate the same issue. I have readjusted the v-wheels, made sure the anti backlash isn’t to tight. I can rotate the Lead Screws by hand with no problem. Could someone please point me on what next to try. Thanks in advance!

@Bill - First check your X motor connection. Motor end and controller end. Check your X dip switch setting. Even if it looks ok flip the switches carefully and back to their original positions. Do that and we can go from there.

@Bill +1 on H’s suggestions.

What version of UGS are you running?

When you say that “everything seems to work” what do you mean?

Ok, checked connections, reset dip switch, when I turn everything back on it lets me jog once then stops, clicks when I try to jog again but no gantry movement. UGS version 2.07-Snapshot/Dec 02, 2020.

When I said everything seems to work, Y-Axis works fine, Z-Axis is fine, X-Axis works initially then stops working, others are fine.

@Bill I know this sounds weird, Bill, but check the motor shaft on your X motor. Others here have had a problem similar to yours and it has turned out to be a broken motor shaft.

At the same time, you can confirm that the motor/lead screw coupler is tight.

Will do but it intermittently works, I read about the couple of motor shafts, mine’s intact, coupler is also tight and in tact. I read some where about using a different Axis to test the box, is that written up anywhere?

Thanks for your help, as you can tell I’m pretty new with this.

Unplug the cables for the X axis and Z axis steppers at the control box. Plug the X cable into Z and the Z cable into X. Then use UGS to try to jog them. If you jog Z on UGS does X axis work? If you jog X on UGS does Z axis work? If you can jog X and Z axis doesn’t work it may be the controller. If you can jog Z and X axis doesn’t work it could be the X cable or stepper motor.

I’m not sure if anyone has asked, but, with the machine of, can you easily turn the X-Axis lead screw? If not, that might be your problem.

1 Like

Yes I can turn the lead screws easily by hand will try switching the cable, thank for the assistance.

@Bill I don’t know if that wire change is written up, but it is simple to do. Reverse the X motor wire and the Z motor wire in the Mill controller. Then, in UGS, jog Z. If X moves as it should, you know the cause of your current problem is not the X motor or the cable going to the X motor.

Then, in UGS, jog Z. If it behaves itself, it may come down to something weird in UGS, since you will have confirmed that the Long Mill controller is fine and so are the motors and the cables.

I expect that when you switch the cables, the X axis will move as it should and the problem will have moved to Z. If that is the case, I think you will have narrowed the problem down to something bad in the controller.

1 Like

Made the switch, both working, will excecise it good tomorrow and see if it will fail. Appreciate all the suggestions. May be time to contact Scienci.

Is it worth mentioning checking the X wires going into the green controller connector? Removing the tinned end and retrimming and reinserting into the connector.

3 Likes

Thanks, will give that a go also.

Good morning Heyward43, well I trimmed off the tinned end of the x wires, failed when used in the x axis jack. Put in in the z axis connector and works perfect. Z axis while plugged into x axis jack fails when exercised constant jogging. Tried source Rabbit to eliminate UGS issues, same problem. Looks to me the issue is the controller has a issue with the x axis jack or internals.

@Bill - Agreed Bill. I would contact Sienci tomorrow. They are pretty good at getting you fixed up. Good luck.

1 Like

I’ve already asked they give me a call, thanks so much for your assistance, much appreciated!

1 Like

Wow, talk about wonderful service, Sienci has already shipped me a new controller, unbelievable service!

Can’t say enough about their support, thanks so much!

2 Likes

@Bill That’s the service that we have come to expect from these guys.

3 Likes

Thanks to all that helped me, new controller arrived last Wednesday and fixed my issue. This forum and the experience to assist a new user like me is invaluable!

I am using gsender and have the same problem with X axis. I switch X and Z, have the same result as you. Let me know if it is resolved please.