Official 0.7.5 Release Thread:

Another Friday, another new release! We’ve got a host of fixes and some re-designed features for you this build! Let’s take a look:

  • Re-designed surfacing tool with new options including zig-zag cutting
  • Numerous fixes for homing, quick-travel, and soft limits
  • Ability to pause and resume in macros using M0/M1 commands
  • Sticky WCS that more accurately reflect which workspace you’re working in
  • Improvements to firmware flashing
  • Graphical fixes and styling changes

What are you having issues with? What would you like to see?

As always, thanks to everyone participating in feedback and bug reporting - it’s helping us make a fantastic product that we are proud of and hope everyone enjoys using. If you’ve given us feedback before and you feel we haven’t yet addressed it, then post it again (maybe we misplaced your comment). We want to get to the point that everyone using it is happy with what it offers to them

1 Like

Can’t wait to try this one out! Thanks for the fixes and improvements.

2 Likes

Problem ONE) When I click on GoTo Zero Y, it goes there, but also to Z-5. I see the following in the console:
feeder G91
feeder G0 Z5
feeder G90
feeder G0 Y0
feeder G0 Z-5

Problem Two) I have jobs that require a tool change with a line like:
M0 ;T202
gSender stops as desired, but since I am doing a tool change, I need to Probe Z again, but it is disabled. As a result I have to split the file into separate jobs.

Carbide Create?
Use a different (Shapeoko) post processor.

Oops. I’d rarely use buttons, but I don’t like the idea of moving an axis I didn’t tell it to move. What if my homing pulloff is set to 1mm or 3mm or what if I am in G20 (not sure if there was anything before that log in the console)?
EDIT: I don’t see this behavior in gSender (0.7.5). @saskia I just see the G90 followed by the G0 Y0

gSender 0.75:
ONE) GoToY0 destroyed a number of my tiny drills by plunging them down into the touch plate which now has little craters at the impact points. Its just a useful shortcut for using the console, which does work correctly.
TWO) The problem is that I cannot Re-zero Z for a new tool I insert during a stop in a job, unless I split the gCode into separate files; a minor annoyance. I don’t think the post-processor has much to do with this functionality.
THREE) MacOS complains that gSender is not from an identified developer so I have to do a security override

The Shapeoko post processor will not add the M0. It will add an M6 (toolchange command).

M6 is not supported (I can easily write a script to swap the commands in a file) and it still will not allow re-probing Z

Pretty sure it is. I’ve used it. I guess it depends what you want to do.
Sounds like what you want to do is

  1. Hit Cancel
  2. Jog around and do your stuff, change your tools.
  3. Hit Resume.
    image

I edited a small Gcode file to try out M6 and M06, and neither give me the dialog about tool change that you show. Just a complaint about it not being supported. Can you post a wee bit of your code that I could try? Is this a firmware issue for the LongMill?

This is what I loaded.
toolChangeTest_twoChanges.nc (17.6 KB)

No.

Updated LongBoard firmware to 1.1h with gSender 0.75
Your code doesn’t work here. Are you using a LongMill?

In your settings. What do you have under tool changes?

That fixed it, settings got unexpectedly reverted to default while trying other stuff. THANKS! I made a bash script to process the Carbide Create files to create a list of tools and to substitute M6 for M0 if there is a T command on the same line as M0.
A better error message could be helpful, saying ignored or whatever instead of “not supported”. Another helpful detail might be if the dialog could include any T command text on the same line as M6 to indicate which tool is expected after the change.

Hello!
When using the GSender “Quick Movement buttons”, it does not seem to move all the way.

My current Firmware Settings:
$130=740 (X Soft Travel)
$131=325 (Y Soft Travel)

After Homing, the “Quick Movement buttons” will move properly:

  • but the X will only reach 712. When i continue to Jog manually, i am able to reach 739 (when i get the “Travel Exceeded” in the Console)
  • but the Y will only reach 310.5. When i continue to Jog manually, i am able to reach 325 (when i get the “Travel Exceeded” in the Console)

Any Ideas?

I’m telling you…just use the Shapeoko Post processor. It’ll do that for you, so you don’t have to post process the post processed.

Nice. I see LongMill machine zero is defined at the position at power-up which is ok for tool change:
(Move to safe Z to avoid workholding)
G53G0Z-5.000
BTW - A little script translates from Excellon 2 drill format to Gcode for PCB drilling for me. I will make more for special purposes. Gcode is easy to deal with in bash.

1 Like

Aaah…I forgot you don’t have homing switches.

Quick movement buttons don’t go all the way to the edge - it’s designed to get “most of the way there” as a convenience movement, but not all the way to avoid running into the machine edge.

It should be travelling 90% of the dimensions configured in preferences for your selected machine profile.

1 Like

@falviani I was wondering what the status was of your issues using gSender with your ‘touch portal’ application that you mentioned back in 0.7.1