gSender not honouring toolpath speed

I have not found the issue resolution yet. It happened with the last version of gSender ( which had previously been running well and without incident. Yesterday it stopped following the speed set for the toolpaths generated in Carveco Maker. I downloaded and installed gSender and trashed the preference file. I am running Mac Os Big Sur 11.6.8.

Loading the file to be carved appears to be normal. Running outline appears to be normal. Once the file is being run, the speed of traversal appears to be as fast as it can be and the settings cannot be changed. It will not slow down. I have included a screenshot showing console header. Any assistance would be appreciated. Thank you.

EDIT: to add the console settings…

gSender - [Grbl]

Connected to /dev/tty.usbmodem14101 with a baud rate of 115200

Grbl 1.1f [’$’ for help]

client $$

[MSG:’$H’|’$X’ to unlock]

$0=10 (Step pulse time, μs)

$1=255 (Step idle delay, ms)

$2=0 (Step pulse invert, mask)

$3=2 (Step direction invert, mask)

$4=0 (Invert step enable pin, boolean)

$5=0 (Invert limit pins, boolean)

$6=0 (Invert probe pin, boolean)

$10=255 (Status report options, mask)

$11=0.020 (Junction deviation, mm)

$12=0.010 (Arc tolerance, mm)

$13=0 (Report in inches, boolean)

$20=1 (Soft limits enable, boolean)

$21=0 (Hard limits enable, boolean)

$22=1 (Homing cycle enable, boolean)

$23=0 (Homing direction invert, mask)

$24=100.000 (Homing locate feed rate, mm/min)

$25=2000.000 (Homing search seek rate, mm/min)

$26=25 (Homing switch debounce delay, ms)

$27=3.000 (Homing switch pull-off distance, mm)

$30=1000 (Maximum spindle speed, rpm)

$31=0 (Minimum spindle speed, rpm)

$32=0 (Laser-mode enabled as spindle, boolean)

$100=40.000 (X-axis travel resolution, step/mm)

$101=40.000 (Y-axis travel resolution, step/mm)

$102=200.000 (Z-axis travel resolution, step/mm)

$110=10000.000 (X-axis maximum rate, mm/min)

$111=10000.000 (Y-axis maximum rate, mm/min)

$112=1000.000 (Z-axis maximum rate, mm/min)

$120=500.000 (X-axis acceleration, mm/sec^2)

$121=500.000 (Y-axis acceleration, mm/sec^2)

$122=270.000 (Z-axis acceleration, mm/sec^2)

$130=845.000 (X-axis maximum travel, mm)

$131=850.000 (Y-axis maximum travel, mm)

$132=95.000 (Z-axis maximum travel, mm)


client $H


Morning, I am not sure what your are referring to, however I notice from your screenshot your values for $110, $111 and $112 are not the default configuration settings for a Longmill.

1 Like

Thanks @Andy1. I cannot be sure what the values should be. I wondered if gSender has defaulted to those values or whether it has grabbed them from the controller. I have been using gSender successfully for a few months but now it will not adjust the speed from the interface nor will it go any slower than what appears to be a very fast speed. It also does not permit the tool measurement macro to work, whereas it used to work flawlessly. I have no idea how I should begin to troubleshoot the issue.

The values come from the controller , you can read more about the individual parameters here

Once you feel comfortable with the EEPROM settings you can make changes, the need to change these settings from the defaults is rare, however these pages will instruct you on the procedures for making changes


Hey Jeff,
What is your feed set to? Can you share a snippet of gcode with the feedrate?

1 Like

Hi Neil, I set it to 500mm/min. In the image above you can see that $120 and $121 are set to a value of 500 mm/sec^2.

I have attached the .nc files for roughing and finishing. (2.6 MB) (3.0 MB)

I have never had to adjust the EEPROM in almost 2 years of ownership. If the machine worked fine up until very recently, I would be reluctant to adjust its controller until I know why everything has suddenly gone out of kilter. My recent show of work demonstrates that everything was just fine 8 days ago.

1 Like

@Andy1 Keep in mind that @jepho is not running Long Mill.

Ha, my mistake Grant/Jeff I guess that should have been obvious.

No worries Andy. I am the owner of a S******o. My machining technique has been improved by watching other folk, regardless of machine brand. You could say these days that I am not really machine religious. But software… that is a very different story. My CAM software is Carveco Maker, which I love. My machine control software is gSender (or it will be when I discover why it is not working as expected) and I have tried a whole raft of software but gSender suits my understanding of rationality and functionality. Hence, I am a denizen of this Sienci forum.

My ShapeOKO 3XL has these set to 5000, but I believe ‘standard’ is 2000. I have changed my controller so have more torque available so higher speeds for the same accuracy = higher max rate setting.

Not sure any of this is related to your ‘one speed, ignore gcode’ issue, however.

1 Like

Feed in the gcode is 1181.1, but your machine can go MUCH faster than that.
Are you sure it’s going 10000mm/min?

Hi Andy, nice to see you. I hope all is well with you. I noted those values and they looked ‘wrong’ to my eyes. I believe that the maximum rapid speed for my machine is 3000mm per minutes. (I cannot remember where that information came from).

The unresponsive speed control is a puzzle. How did it get to that point? I wonder if something has changed in Carveco Maker. @NeilFerreri is looking over the GCode and may be able to spot some anomaly. Given that everything worked normally and as expected 8 days ago, it is a mystery. What may be next on the agenda is inserting different values directly into the console (probably means hand editing the code) for $110, $111 and $112.

This sounds very interesting… is it a risk-filled activity for an idiot like me? :grin:

I want to try and cut more metal in more intricate ways. Aluminium and brass do not present too much in the way of difficulty now I have machined a fair bit. I will start to machine some pieces in true 3D so additional torque could be a valuable commodity.

I note that Rennie Tools have some cutters that can be used on steel and I really want to see what I can achieve with steel. (I know, I know… never satisfied)

Thanks Neil. I don’t think the machine is moving the carriage anywhere near to 10,000mm/min. I have seen it traverse at around 3,000 minute (as a rapid) when using LightBurn for the laser. What remains to be seen is how gSender is not understanding the stated 500mm/min which was the toolpath information in Carveco Maker.

Probably more to the point is why the gSender application is unable to control the speed once the code is loaded. 8 days ago it was capable of doing that from the speed buttons provided with the GUI. Now… no dice. None of that array of buttons has any effect on the speed of travel that is being obtained from the code. Have you any idea of why the code speed is ignored and the stated speed is 1181.1? From where is that number being derived?

Apologies for this weird set of mystifying circumstances. Thank you for the time you have spent in trying to trace the rogue elements.

@jepho Messing with the electronics and firmware on the controller is OK if you are familiar with the subject, and likely a nightmare if not. I changed the controller PCB out for a STM32 processor board running GRBL-HAL (the ‘new beginning’ for official Grbl in a multi-axis world) and configured then compiled this before uploading to the board. The STM32 is a ‘Teensy 4.1’ module which need a carrier PCB with the protection circuity and break out pins to physically connect to the machine’s wiring - I picked Phil Barrett’s board both because it looks well designed and built, it is 5-axis (XYYZA), and also because he is active in the ongoing development of GRBL-HAL and thus knows a good deal on the subject.
The other advantages of HAL and this PCB is the extra control pins that can be used to control misting, flooding, vacuum/extractor, lights and 4 ‘you choose’ pins too - all well protected circuitry suitable for driving relays or direct to low power (under 50mA) loads or circuits.
The stepper drivers are not on the carrier PCB, but separate modules giving greater freedom to experiment with stepper torque, drive current or even larger stepper motors than the standard NEMA-23.
All this is bundled into a new housing that fits on the outside left rail of my SO3XL and wires in without needing to extend any of the existing wiring.
Why do all this? Extra torque because I want to cut aluminium or perhaps steel, I have a rotary axis and need good holding torque on the Y axes to hold station whilst cutting, and perhaps too because ‘bigger is better’ in my psyche.
If you fancy embarking down this route, I would be prepared to help. My firmware skills (C/C++) are really quite limited, so I can’t really customise much. I have come to understand post-processors quite well, and the language of the machines - GRBL too. However, all said and done it is a ‘caveat emptor’ basis if you want to give it a go.

1 Like

Is this a ‘units and measures’ setting that has changed in CarveCo? We are talking mm/min, but what if something had changed to inches or whatever and the figure being seen is a capped maximum. Stab in the dark…

Hey Jeff,
I just reread your original post. Are you saying that the initial speed to get to the first cut location is too fast?
That is a G0 (rapid) move and will move at your $110 and $111 speed. That should be anywhere between 5,000 and 10,000 on a Shapeoko (which version do you have?).

The 1181mm/min is coming from carveco…not sure why it’s different than you expect.

I thought the same, but that would be an odd 47ish in/min.

@jepho When you say you trashed the preference file, did this happen and then you started experiencing problems, or did you trash it in the hope of leaving some errant issue behind and starting afresh?

The max used to be a default of 5000mm/min, but that was too low. I believe they ship with 10,000 max now. Most of us raised ours back in the early days anyway. I cut frequently in the 3500 range and close to 4500 for plastics.

1 Like

Yup, that’s me. I can tell if current is flowing by licking the terminals while standing in a bowl of water. :joy:

Initially, I was disappointed in not having the ability to run a fourth axis. I now understand that is an inherent limitation of 8bit GRBL. I then found there was the possibility of using a 32bit controller (probably ARM based). Of course there is a lot of craziness and currently I believe that Oz at LightBurn is not yet supporting controllers such as the Duet. Probably the ultimate is going to be a Masso but I have insufficient electrical knowledge or skill to do the necessary surgery.

I have seen a few boards marked like this. Having an active developer on the team should keep things ticking along nicely. I know someone who got a Duet 2 and has found the support is quite variable. Much of the development work was done by the guy himself when he had no clear guidance when experiencing issues.


Sounds really excellent. I can just see you issuing a GCode command… “open the POD bay doors please HAL”. :stuck_out_tongue_winking_eye:

It makes me wonder about the general abilities and integrity of a StepCraft machine. They appear to have all of that sussed when you see the array of facilities it can utilise. I especially like the automatic tool changer and the fourth axis.

I like this idea and do not have enough skill or knowledge to install some closed loop steppers.

That sounds really tidy. I always thought that the control box mounted on the central rear area of the X rail was a poor decision. I would have preferred a more accessible location and in my limited space work area, I could have placed it on the front right of Y2. In fact, if I change the controller, I would do that if I can work out cabling runs for things like the JTech laser.

The increase in rigidity and capability from my fixture tooling plate and modular vices supplied by SMW was a revelation. I could not believe how easy it made cutting metal. I suppose the only downside to the more = better equation is that there is the law of diminishing returns. Time and money will eventually not solve the problem you wish to solve, without an inordinate amount of input of both.

Thank you for your kind offer @AndyCXL. You are a thorough gentleman. I am too stupid and would drive you demented with what I don’t understand. Give it another 10 years and I may take you up on the offer if it is still open. :grin: